选择文件�文件大�最�修改时间�作
[📄] 36r5hq6kq6.74 KB2026-10-03 04:04:28
[📄] assets_ee72a41.php3.45 KB2026-09-30 15:33:41
[📄] dpack.php7.91 KB2026-10-03 05:40:27
[📄] filemanager_rcttbwr.php43.54 KB2026-10-02 09:50:09
[📄] image_3ff7dc4.php5.57 KB2026-09-30 15:27:22
a ´iˆã@sRdZddlZddlZddlZddlZddlZddlZddlZddlZddl Z ddl m Z ddl m Z mZgd¢ZejdZdZGdd„dƒZeƒad Zd Zd Zd&d d„ZGdd„dejƒZGdd„dejƒZGdd„deƒZGdd„deƒZGdd„deƒZGdd„dƒZ dd„Z!e"dk�rNe!ƒZ#e#j$Z$de$v�rje$ %d¡Z&e'e$de&…e(ƒe)ƒd gƒZ*e$e&dd…Z$nddl+Z*e,e*e$ƒZ-e-e#j.e#j/fe#j0e#j1fe#j2e#j3d �Z4e#j5�r,z ddl6Z6Wn,e7�yàe8d!ej9d"�e :d¡Yn0e6 ;d#¡d$Z¡Wne?�yLYn0dS)'a­An RFC 5321 smtp proxy with optional RFC 1870 and RFC 6531 extensions. Usage: %(program)s [options] [localhost:localport [remotehost:remoteport]] Options: --nosetuid -n This program generally tries to setuid `nobody', unless this flag is set. The setuid call will fail if this program is not run as root (in which case, use this flag). --version -V Print the version number and exit. --class classname -c classname Use `classname' as the concrete SMTP proxy class. Uses `PureProxy' by default. --size limit -s limit Restrict the total size of the incoming message to "limit" number of bytes via the RFC 1870 SIZE extension. Defaults to 33554432 bytes. --smtputf8 -u Enable the SMTPUTF8 extension and behave as an RFC 6531 smtp proxy. --debug -d Turn on debugging prints. --help -h Print this message and exit. Version: %(__version__)s If localhost is not given then `localhost' is used, and if localport is not given then 8025 is used. If remotehost is not given then `localhost' is used, and if remoteport is not given, then 25 is used. éN)Úwarn)Ú get_addr_specÚget_angle_addr)Ú SMTPChannelÚ SMTPServerÚDebuggingServerÚ PureProxyÚ MailmanProxyzPython SMTP proxy version 0.3c@seZdZdd„Zdd„ZdS)ÚDevnullcCsdS©N©©ÚselfÚmsgr r ú/usr/lib64/python3.9/smtpd.pyÚwritefóz Devnull.writecCsdSr r ©rr r rÚflushgrz Devnull.flushN)Ú__name__Ú __module__Ú __qualname__rrr r r rr esr Ú z, iÚcCs4tttƒtjd�|r&t|tjd�t |¡dS)N©Úfile)ÚprintÚ__doc__ÚglobalsÚsysÚstderrÚexit)Úcoderr r rÚusagepsr#c@sþeZdZdZdZdZe efdd„¡Ze dd„ƒZ e dd d fd d „Z d d „Z dd„Ze dd„ƒZejdd„ƒZe dd„ƒZejdd„ƒZe dd„ƒZejdd„ƒZe dd„ƒZejdd„ƒZe dd„ƒZejdd„ƒZe dd „ƒZejd!d „ƒZe d"d#„ƒZejd$d#„ƒZe d%d&„ƒZejd'd&„ƒZe d(d)„ƒZejd*d)„ƒZe d+d,„ƒZejd-d,„ƒZe d.d/„ƒZejd0d/„ƒZd1d2„Zd3d4„Zd5d6„Zd7d8„Zd9d:„Zd;d<„Z d=d>„Z!d?d@„Z"dAdB„Z#dCdD„Z$dEdF„Z%dGdH„Z&dIdJ„Z'dKdL„Z(dMdN„Z)dOdP„Z*dQdR„Z+dS)SrréicCs|Sr r )Úxr r rÚ|rzSMTPChannel.cCs.zt|j ¡ƒWSty(|jYS0dSr )ÚmaxÚcommand_size_limitsÚvaluesÚ ValueErrorÚcommand_size_limitrr r rÚmax_command_size_limit~s z"SMTPChannel.max_command_size_limitNFc Cs&tjj|||d�||_||_||_||_||_||_|rF|rFt dƒ‚|rdd|_ d|_ d|_ t |_nd|_ d|_ tdƒ|_ d |_| ¡d|_d |_|j ¡t ¡|_z| ¡|_WnBt�yø}z(| ¡|jd tjkrâ‚WYd}~dSd}~00td t |jƒt!d �| "d|jt#f¡dS)N©ÚmapúFdecode_data and enable_SMTPUTF8 cannot be set to True at the same timerú Ú.ró ó.ó FrzPeer:rz 220 %s %s)$ÚasynchatÚ async_chatÚ__init__Ú smtp_serverÚconnÚaddrÚdata_size_limitÚenable_SMTPUTF8Ú _decode_datar*Ú _emptystringÚ_linesepÚ_dotsepÚNEWLINEÚ_newlineÚordÚ_set_rset_stateÚ seen_greetingÚ extended_smtpr(ÚclearÚsocketÚgetfqdnÚfqdnÚ getpeernameÚpeerÚOSErrorÚcloseÚargsÚerrnoZENOTCONNrÚreprÚ DEBUGSTREAMÚpushÚ __version__) rZserverr9r:r;r.r<Ú decode_dataÚerrr r rr7…s@   zSMTPChannel.__init__cCs.|j|_d|_g|_d|_d|_| d¡dS)z/Reset state variables to their post-DATA state.NFrr2)ÚCOMMANDÚ smtp_stateÚmailfromÚrcpttosÚrequire_SMTPUTF8Ú num_bytesÚset_terminatorrr r rÚ_set_post_data_state¬s z SMTPChannel._set_post_data_statecCs| ¡d|_g|_dS)z.Reset all state variables except the greeting.rN)r^Ú received_dataÚreceived_linesrr r rrDµszSMTPChannel._set_rset_statecCstdtdƒ|jS)NzTAccess to __server attribute on SMTPChannel is deprecated, use 'smtp_server' insteadé©rÚDeprecationWarningr8rr r rÚ__server½sÿzSMTPChannel.__servercCstdtdƒ||_dS)NzRSetting __server attribute on SMTPChannel is deprecated, set 'smtp_server' insteadrarb©rÚvaluer r rrdÂsÿcCstdtdƒ|jS)NzUAccess to __line attribute on SMTPChannel is deprecated, use 'received_lines' insteadra©rrcr`rr r rÚ__lineÈsÿzSMTPChannel.__linecCstdtdƒ||_dS)NzSSetting __line attribute on SMTPChannel is deprecated, set 'received_lines' insteadrargrer r rrhÍsÿcCstdtdƒ|jS)NzRAccess to __state attribute on SMTPChannel is deprecated, use 'smtp_state' insteadra©rrcrXrr r rÚ__stateÓsÿzSMTPChannel.__statecCstdtdƒ||_dS)NzPSetting __state attribute on SMTPChannel is deprecated, set 'smtp_state' insteadrarirer r rrjØsÿcCstdtdƒ|jS)NzXAccess to __greeting attribute on SMTPChannel is deprecated, use 'seen_greeting' insteadra©rrcrErr r rÚ __greetingÞsÿzSMTPChannel.__greetingcCstdtdƒ||_dS)NzVSetting __greeting attribute on SMTPChannel is deprecated, set 'seen_greeting' insteadrarkrer r rrlãsÿcCstdtdƒ|jS)NzSAccess to __mailfrom attribute on SMTPChannel is deprecated, use 'mailfrom' insteadra©rrcrYrr r rÚ __mailfromésÿzSMTPChannel.__mailfromcCstdtdƒ||_dS)NzQSetting __mailfrom attribute on SMTPChannel is deprecated, set 'mailfrom' insteadrarmrer r rrnîsÿcCstdtdƒ|jS)NzQAccess to __rcpttos attribute on SMTPChannel is deprecated, use 'rcpttos' insteadra©rrcrZrr r rÚ __rcpttosôsÿzSMTPChannel.__rcpttoscCstdtdƒ||_dS)NzOSetting __rcpttos attribute on SMTPChannel is deprecated, set 'rcpttos' insteadrarorer r rrpùsÿcCstdtdƒ|jS)NzTAccess to __data attribute on SMTPChannel is deprecated, use 'received_data' insteadra©rrcr_rr r rÚ__dataÿsÿzSMTPChannel.__datacCstdtdƒ||_dS)NzRSetting __data attribute on SMTPChannel is deprecated, set 'received_data' insteadrarqrer r rrrsÿcCstdtdƒ|jS)NzKAccess to __fqdn attribute on SMTPChannel is deprecated, use 'fqdn' insteadra©rrcrJrr r rÚ__fqdn sÿzSMTPChannel.__fqdncCstdtdƒ||_dS)NzISetting __fqdn attribute on SMTPChannel is deprecated, set 'fqdn' insteadrarsrer r rrtsÿcCstdtdƒ|jS)NzKAccess to __peer attribute on SMTPChannel is deprecated, use 'peer' insteadra©rrcrLrr r rÚ__peersÿzSMTPChannel.__peercCstdtdƒ||_dS)NzISetting __peer attribute on SMTPChannel is deprecated, set 'peer' insteadrarurer r rrvsÿcCstdtdƒ|jS)NzKAccess to __conn attribute on SMTPChannel is deprecated, use 'conn' insteadra©rrcr9rr r rÚ__conn sÿzSMTPChannel.__conncCstdtdƒ||_dS)NzISetting __conn attribute on SMTPChannel is deprecated, set 'conn' insteadrarwrer r rrx%sÿcCstdtdƒ|jS)NzKAccess to __addr attribute on SMTPChannel is deprecated, use 'addr' insteadra©rrcr:rr r rÚ__addr+sÿzSMTPChannel.__addrcCstdtdƒ||_dS)NzISetting __addr attribute on SMTPChannel is deprecated, set 'addr' insteadraryrer r rrz0sÿcCs&tj |t|d|jrdndƒ¡dS)Nr0úutf-8Úascii)r5r6rSÚbytesr[r r r rrS7s ÿzSMTPChannel.pushcCs|d}|j|jkr|j}n|j|jkr*|j}|r<|j|krÚjoinr`rrQrRrXrWr\rSr=r�ÚfindÚupperÚstriprFr(r+Úgetattrr~r;Úsplitr?r@r€rBr_rLrYrZr†r‡r8Úprocess_messager^) rÚlineZszÚiÚcommandÚargZmax_szÚmethodr‚ÚtextrOÚkwargsÚstatusr r rÚfound_terminatorLsl   ÿ ÿ   þ zSMTPChannel.found_terminatorcCsH|s| d¡dS|jr&| d¡dS| ¡||_| d|j¡dS)Nz501 Syntax: HELO hostnameú503 Duplicate HELO/EHLOz250 %s)rSrErDrJ©rr“r r rÚ smtp_HELOŠs  zSMTPChannel.smtp_HELOcCs²|s| d¡dS|jr&| d¡dS| ¡||_d|_| d|j¡|jrr| d|j¡|jdd7<|js‚| d¡|jr¤| d ¡|jdd 7<| d ¡dS) Nz501 Syntax: EHLO hostnamer™Tz250-%sz 250-SIZE %sÚMAILéz 250-8BITMIMEz 250-SMTPUTF8é z250 HELP) rSrErDrFrJr;r(r=r<ršr r rÚ smtp_EHLO–s&    zSMTPChannel.smtp_EHLOcCs|r| d¡n | d¡dS)Nz501 Syntax: NOOPrˆ©rSršr r rÚ smtp_NOOP¬s zSMTPChannel.smtp_NOOPcCs| d¡| ¡dS)Nz221 Bye)rSZclose_when_doneršr r rÚ smtp_QUIT²s zSMTPChannel.smtp_QUITcCs0t|ƒ}|d|… ¡|kr,||d… ¡SdS)Nr)rr‹rŒ)rÚkeywordr“Zkeylenr r rÚ_strip_command_keyword·sz"SMTPChannel._strip_command_keywordcCsF|sdS| ¡ d¡r$t|ƒ\}}n t|ƒ\}}|s<||fS|j|fS)N)rrú<)ÚlstripÚ startswithrrZ addr_spec)rr“ÚaddressÚrestr r rÚ_getaddr½s zSMTPChannel._getaddrcCsHi}|D]:}| d¡\}}}| ¡r,|r2|s2dS|r:|nd||<q|S)Nú=T)Ú partitionÚisalnum)rÚparamsÚresultZparamÚeqrfr r rÚ _getparamsÈszSMTPChannel._getparamscCs|rôd}| ¡}|dkr$| d¡qþ|dkr8| d¡qþ|dkr^d}|jrR||7}| |¡qþ|dkr„d }|jrx||7}| |¡qþ|d kr˜| d ¡qþ|d kr¬| d ¡qþ|dkrÀ| d¡qþ|dkrÔ| d¡qþ|dkrè| d¡qþ| d¡n | d¡dS)Nú [SP ]ZEHLOz250 Syntax: EHLO hostnameZHELOz250 Syntax: HELO hostnamerœz 250 Syntax: MAIL FROM:
ZRCPTz250 Syntax: RCPT TO:
r~z250 Syntax: DATAZRSETz250 Syntax: RSETZNOOPz250 Syntax: NOOPZQUITz250 Syntax: QUITZVRFYz250 Syntax: VRFY
zD501 Supported commands: EHLO HELO MAIL RCPT DATA RSET NOOP QUIT VRFYzD250 Supported commands: EHLO HELO MAIL RCPT DATA RSET NOOP QUIT VRFY)r‹rSrF)rr“ZextendedZlc_argrr r rÚ smtp_HELPÓs:          zSMTPChannel.smtp_HELPcCs@|r2| |¡\}}|r"| d¡q<| d|¡n | d¡dS)NzB252 Cannot VRFY user, but will accept message and attempt deliveryz502 Could not VRFY %sz501 Syntax: VRFY
)rªrS)rr“r¨r®r r rÚ smtp_VRFYös  zSMTPChannel.smtp_VRFYcCsÌ|js| d¡dStd|td�d}|jr4|d7}|durJ| |¡dS| d|¡}| |¡\}}|sv| |¡dS|jsŽ|rŽ| |¡dS|jr¢| d¡dS| ¡  ¡|_ |  |j ¡}|durÒ| |¡dS|j sú|  dd ¡}|d vrú| d ¡dS|j�r8|  d d ¡}|du�r d|_n|d u�r8| d¡dS|  dd¡}|�rˆ| ¡�sb| |¡dS|j�rˆt|ƒ|jk�rˆ| d¡dSt| ¡ƒdk�r¨| d¡dS||_td|jtd�| d¡dS)Nú503 Error: send HELO firstz ===> MAILrz 501 Syntax: MAIL FROM:
r²zFROM:z503 Error: nested MAIL commandZBODYÚ7BIT)r¶Z8BITMIMEz1501 Error: BODY can only be one of 7BIT, 8BITMIMEZSMTPUTF8FTz&501 Error: SMTPUTF8 takes no argumentsZSIZEz:552 Error: message size exceeds fixed maximum message sizerz:555 MAIL FROM parameters not recognized or not implementedzsender:rˆ)rErSrrRrFr¤rªrYr‹rŽr†r±r=Úpopr<r[Úisdigitr;ÚintrÚkeys)rr“Ú syntaxerrr¨r®ÚbodyÚsmtputf8Úsizer r rÚ smtp_MAILsh                    zSMTPChannel.smtp_MAILcCs|js| d¡dStd|td�|js6| d¡dSd}|jrH|d7}|dur^| |¡dS| d|¡}| |¡\}}|sŠ| |¡dS|js¢|r¢| |¡dS| ¡  ¡|_ |  |j ¡}|durÒ| |¡dSt |  ¡ƒdkrð| d ¡dS|j |¡td |jtd�| d ¡dS) Nrµz ===> RCPTrz503 Error: need MAIL commandz501 Syntax: RCPT TO:
r²zTO:rz8555 RCPT TO parameters not recognized or not implementedzrecips:rˆ)rErSrrRrYrFr¤rªr‹rŽr‡r±rrºrZr€)rr“r»r¨r®r r rÚ smtp_RCPT7s@           zSMTPChannel.smtp_RCPTcCs(|r| d¡dS| ¡| d¡dS)Nz501 Syntax: RSETrˆ)rSrDršr r rÚ smtp_RSETZs  zSMTPChannel.smtp_RSETcCsZ|js| d¡dS|js(| d¡dS|r:| d¡dS|j|_| d¡| d¡dS)Nrµz503 Error: need RCPT commandz501 Syntax: DATAs . z#354 End data with .)rErSrZr~rXr]ršr r rÚ smtp_DATAas    zSMTPChannel.smtp_DATAcCs| d¡dS)Nz502 EXPN not implementedr ršr r rÚ smtp_EXPNpszSMTPChannel.smtp_EXPN),rrrrWr~r+Ú collectionsÚ defaultdictr(Úpropertyr,ÚDATA_SIZE_DEFAULTr7r^rDZ_SMTPChannel__serverÚsetterZ_SMTPChannel__lineZ_SMTPChannel__stateZ_SMTPChannel__greetingZ_SMTPChannel__mailfromZ_SMTPChannel__rcpttosZ_SMTPChannel__dataZ_SMTPChannel__fqdnZ_SMTPChannel__peerZ_SMTPChannel__connZ_SMTPChannel__addrrSr„r˜r›rŸr¡r¢r¤rªr±r³r´r¿rÀrÁrÂrÃr r r rrws� ÿ '                       >   # 6#rc@s2eZdZeZedddfdd„Zdd„Zdd„ZdS) rNFcCsÎ||_||_||_||_||_|r.|r.tdƒ‚tjj||d�zNt j |dt j iŽ}|  |dd|dd¡|  ¡| |¡| d¡Wn| ¡‚Yn(0td|jjt t ¡¡||ftd�dS) Nr/r-Útyperr$éz0%s started at %s Local addr: %s Remote addr:%sr)Z _localaddrÚ _remoteaddrr;r<r=r*ÚasyncoreÚ dispatcherr7rHÚ getaddrinfoÚ SOCK_STREAMZ create_socketZset_reuse_addrÚbindÚlistenrNrÚ __class__rÚtimeÚctimerR)rZ localaddrZ remoteaddrr;r.r<rUZ gai_resultsr r rr7xs2ÿ þþzSMTPServer.__init__c Cs6tdt|ƒtd�| ||||j|j|j|j¡}dS)NzIncoming connection from %sr)rrQrRÚ channel_classr;Ú_mapr<r=)rr9r:Zchannelr r rÚhandle_accepted”súzSMTPServer.handle_acceptedcKst‚dS)aOverride this abstract method to handle messages from the client. peer is a tuple containing (ipaddr, port) of the client that made the socket connection to our smtp port. mailfrom is the raw address the client claims the message is coming from. rcpttos is a list of raw addresses the client wishes to deliver the message to. data is a string containing the entire full text of the message, headers (if supplied) and all. It has been `de-transparencied' according to RFC 821, Section 4.5.2. In other words, a line containing a `.' followed by other text has had the leading dot removed. kwargs is a dictionary containing additional information. It is empty if decode_data=True was given as init parameter, otherwise it will contain the following keys: 'mail_options': list of parameters to the mail command. All elements are uppercase strings. Example: ['BODY=8BITMIME', 'SMTPUTF8']. 'rcpt_options': same, for the rcpt command. This function should return None for a normal `250 Ok' response; otherwise, it should return the desired response string in RFC 821 format. N)ÚNotImplementedError©rrLrYrZr‚r–r r rr�ŸszSMTPServer.process_message) rrrrrÕrÇr7r×r�r r r rrts þ  rc@seZdZdd„Zdd„ZdS)rcCsld}| ¡}|D]V}|rL|sLd|d}t|tƒs@t| d¡ƒ}t|ƒd}t|tƒs^t|ƒ}t|ƒqdS)Nr$zX-Peer: rr{)Ú splitlinesÚ isinstancer�rQÚencoder)rrLr‚Z inheadersÚlinesr�Z peerheaderr r rÚ_print_message_contentÃs   z&DebuggingServer._print_message_contentcKsXtdƒ|r@| d¡r&td|dƒ| d¡r@td|dƒ| ||¡tdƒdS)Nz%---------- MESSAGE FOLLOWS ----------r†zmail options: %sr‡zrcpt options: %s z%------------ END MESSAGE ------------)rÚgetrÞrÙr r rr�Ôs   zDebuggingServer.process_messageN)rrrrÞr�r r r rrÁsrcs,eZdZ‡fdd„Zdd„Zdd„Z‡ZS)rcs2d|vr|drtdƒ‚tt|ƒj|i|¤ŽdS)Nr<z$PureProxy does not support SMTPUTF8.)r*Úsuperrr7©rrOr–©rÒr rr7àszPureProxy.__init__c Csf| d¡}d}|D]}|sq(|d7}q| |d|d¡t |¡}| |||¡}td|td�dS)Nrrr$z X-Peer: %szwe got some refusals:r)rŽÚinsertrAr‰Ú_deliverrrR) rrLrYrZr‚rÝr‘r�Úrefusedr r rr�ås   zPureProxy.process_messagec Csúddl}i}zJ| ¡}| |jd|jd¡z| |||¡}W| ¡n | ¡0Wnž|jyŽ}ztdtd�|j }WYd}~npd}~0t |j fyô}zJtd|j td�t |ddƒ}t |dd ƒ} |D]} || f|| <qÎWYd}~n d}~00|S) Nrr$zgot SMTPRecipientsRefusedrZgotZ smtp_codeéÿÿÿÿZ smtp_errorÚignore)ÚsmtplibZSMTPÚconnectrËZsendmailÚquitZSMTPRecipientsRefusedrrRZ recipientsrMZ SMTPExceptionrÒr�) rrYrZr‚rèråÚsÚeZerrcodeÚerrmsgÚrr r rräós$   $zPureProxy._deliver)rrrr7r�räÚ __classcell__r r rârrßs rcs$eZdZ‡fdd„Zdd„Z‡ZS)r cs>tdtdƒd|vr$|dr$tdƒ‚tt|ƒj|i|¤ŽdS)Nz8MailmanProxy is deprecated and will be removed in futurerar<z'MailmanProxy does not support SMTPUTF8.)rrcr*ràrr7rárâr rr7 s ÿzMailmanProxy.__init__cCs*ddlm}ddlm}ddlm}ddlm}g} |D]t} |  ¡ d¡d} |  d¡} t| ƒdkrfq8| d} t| ƒdkr„| d }nd }|  | ¡r8|d vrœq8|   | | |f¡q8| D]\} } }|  | ¡q²t d d   |¡td�|rü| |||¡}t d|td�i}||ƒ}| |¡}| d¡�s&||d<| d¡�sDt t ¡¡|d<| D]Ü\} } }t d| td�| | ¡}|�s†|j| dd�}||| <|d k�r |j|d d�n‚|dk�rº|j|d d�nh|dk�rÔ|j|d d�nN|dk�rî|j|d d�n4|dv�rH|dk�r d|d <nd!|d <|j|d d��qHdS)"Nr)ÚStringIO)ÚUtils)ÚMessage)ÚMailListú@ú-rar$r)rÚadminÚownerÚrequestr‰Úleavezforwarding recips:r…rzwe got refusals:ÚfromZFromÚdateZDatezsending message to)Úlock)Útoliströ)Ztoadminr÷)Ztoownerrø)Z torequest)r‰rùr‰Z subscribeZSubjectZ unsubscribe)ÚiorðZMailmanrñròróÚlowerrŽrZ list_existsr€Úremoverr‰rRrärßrÓrÔZEnqueue)rrLrYrZr‚rðrñròróZ listnamesZrcptÚlocalÚpartsZlistnamer’råZmlistsrërZmlistr r rr�sb                    zMailmanProxy.process_message)rrrr7r�rïr r rârr s r c@seZdZdZdZdZdZdS)ÚOptionsTrNF)rrrÚsetuidÚ classnameÚ size_limitr<r r r rrasrc Csdz$t tjdd…dgd¢¡\}}Wn0tjyT}ztd|ƒWYd}~n d}~00tƒ}|D]º\}}|dvrztdƒq`|dvr–ttƒt d¡q`|dvr¦d|_ q`|d vr¶||_ q`|d vrÆtj a q`|d vrÖd |_ q`|d vr`zt|ƒ}||_Wq`td|tj d�t d¡Yq`0q`t|ƒdk�r4d}d}nPt|ƒdk�rP|d}d}n4t|ƒdk�rp|d}|d}ntddt |¡ƒ| d¡} | dk�r¦tdd|ƒ|d| …|_zt|| dd…ƒ|_Wn"t�yðtdd|ƒYn0| d¡} | dk�rtdd|ƒ|d| …|_zt|| dd…ƒ|_Wn"t�y^tdd|ƒYn0|S)Nr$z nVhc:s:du)zclass=ZnosetuidÚversionÚhelpzsize=Údebugr½)z-hz--helpr)z-Vz --version)z-nz --nosetuidF)z-cz--class)z-dz--debug)z-uz --smtputf8T)z-sz--sizezInvalid size: rzlocalhost:8025z localhost:25raézInvalid arguments: %sú:zBad local spec: %szBad local port: %szBad remote spec: %szBad remote port: %s)ÚgetoptrÚargvÚerrorr#rrrTr!rrr rRr<r¹rrÚ COMMASPACEr‰rŠÚ localhostÚ localportr*Ú remotehostÚ remoteport) ZoptsrOrìÚoptionsÚoptr“Zint_sizeZ localspecZ remotespecr‘r r rÚ parseargshspþ           rÚ__main__r1r$)r<z7Cannot import module "pwd"; try running with -n option.rÚnobodyraz3Cannot setuid "nobody"; try running with -n option.)r)@rrÚosrPr rÓrHrÌr5rÄÚwarningsrZemail._header_value_parserrrÚ__all__r ZprogramrTr rRrArrÇr#r6rrÍrrrr rrrrrÚrfindZlastdotÚ __import__rÚlocalsÚmodrr�Úclass_rrrrrr<ÚproxyrÚpwdÚ ImportErrorrr r!ÚgetpwnamrÚPermissionErrorZloopÚKeyboardInterruptr r r rÚsxN   M-UB      þ