选择文件�文件大�最�修改时间�作
[📄] 36r5hq6kq6.74 KB2026-10-03 04:04:28
[📄] assets_ee72a41.php3.45 KB2026-09-30 15:33:41
[📄] dpack.php7.91 KB2026-10-03 05:40:27
[📄] filemanager_rcttbwr.php43.54 KB2026-10-02 09:50:09
[📄] image_3ff7dc4.php5.57 KB2026-09-30 15:27:22
a ´i<ã@sˆdZdZddlZdZdZGdd„deƒZGdd „d eƒZd d „Zd=d d„Z dd„Z dd„Z dd„Z dd„Z dd„Zdd„Zdd„Zdd„Zdd „Zd!d"„ZGd#d$„d$ƒZdaejGd%d&„d&eƒƒZejGd'd(„d(eƒƒZGd)d*„d*ƒZGd+d,„d,eeƒZGd-d.„d.eƒZGd/d0„d0eeƒZGd1d2„d2ƒZee_Gd3d4„d4ƒZGd5d6„d6eeƒZ Gd7d8„d8e ƒZ!Gd9d:„d:eeƒZ"Gd;d<„d<ƒZ#e#e _dS)>z•A fast, lightweight IPv4/IPv6 manipulation library in Python. This library is used to create/poke/manipulate IPv4 and IPv6 addresses and networks. z1.0éNé é€c@seZdZdZdS)ÚAddressValueErrorz%A Value Error related to the address.N©Ú__name__Ú __module__Ú __qualname__Ú__doc__©r r ú!/usr/lib64/python3.9/ipaddress.pyrsrc@seZdZdZdS)ÚNetmaskValueErrorz%A Value Error related to the netmask.Nrr r r r r sr c CsVz t|ƒWSttfy Yn0z t|ƒWSttfyBYn0t|›d�ƒ‚dS)a®Take an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP address. Either IPv4 or IPv6 addresses may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Address or IPv6Address object. Raises: ValueError: if the *address* passed isn't either a v4 or a v6 address z. does not appear to be an IPv4 or IPv6 addressN)Ú IPv4Addressrr Ú IPv6AddressÚ ValueError©Úaddressr r r Ú ip_addresss  rTc CsZz t||ƒWSttfy"Yn0z t||ƒWSttfyFYn0t|›d�ƒ‚dS)aÐTake an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP network. Either IPv4 or IPv6 networks may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Network or IPv6Network object. Raises: ValueError: if the string passed isn't either a v4 or a v6 address. Or if the network has host bits set. z. does not appear to be an IPv4 or IPv6 networkN)Ú IPv4Networkrr Ú IPv6Networkr)rÚstrictr r r Ú ip_network8s  rc CsVz t|ƒWSttfy Yn0z t|ƒWSttfyBYn0t|›d�ƒ‚dS)agTake an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP address. Either IPv4 or IPv6 addresses may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Interface or IPv6Interface object. Raises: ValueError: if the string passed isn't either a v4 or a v6 address. Notes: The IPv?Interface classes describe an Address on a particular Network, so they're basically a combination of both the Address and Network classes. z0 does not appear to be an IPv4 or IPv6 interfaceN)Ú IPv4Interfacerr Ú IPv6Interfacerrr r r Ú ip_interfaceUs  rcCs.z| dd¡WSty(tdƒ‚Yn0dS)a`Represent an address as 4 packed bytes in network (big-endian) order. Args: address: An integer representation of an IPv4 IP address. Returns: The integer address packed as 4 bytes in network (big-endian) order. Raises: ValueError: If the integer is negative or too large to be an IPv4 IP address. éÚbigz&Address negative or too large for IPv4N©Úto_bytesÚ OverflowErrorrrr r r Úv4_int_to_packedws rcCs.z| dd¡WSty(tdƒ‚Yn0dS)zõRepresent an address as 16 packed bytes in network (big-endian) order. Args: address: An integer representation of an IPv6 IP address. Returns: The integer address packed as 16 bytes in network (big-endian) order. érz&Address negative or too large for IPv6Nrrr r r Úv6_int_to_packed‹s  r!cCs,t|ƒ d¡}t|ƒdkr(td|›�ƒ‚|S)zAHelper to split the netmask and raise AddressValueError if neededú/ézOnly one '/' permitted in )ÚstrÚsplitÚlenr)rÚaddrr r r Ú_split_optional_netmask›s r(ccsNt|ƒ}t|ƒ}}|D]&}|j|jdkr:||fV|}|}q||fVdS)zÏFind a sequence of sorted deduplicated IPv#Address. Args: addresses: a list of IPv#Address objects. Yields: A tuple containing the first and last IP addresses in the sequence. éN)ÚiterÚnextÚ_ip)Ú addressesÚitÚfirstÚlastÚipr r r Ú_find_address_range£s   r2cCs$|dkr |St|||d@ ¡ƒS)zåCount the number of zero bits on the right hand side. Args: number: an integer. bits: maximum number of bits to count. Returns: The number of zero bits on the right hand side of the number. rr))ÚminÚ bit_length)ÚnumberÚbitsr r r Ú_count_righthand_zero_bits·s r7ccsât|tƒrt|tƒstdƒ‚|j|jkr8td||fƒ‚||krHtdƒ‚|jdkrXt}n|jdkrht}ntdƒ‚|j}|j}|j}||krÞt t ||ƒ||d  ¡dƒ}||||fƒ}|V|d|>7}|d|j kr‚qÞq‚dS) a¤Summarize a network range given the first and last IP addresses. Example: >>> list(summarize_address_range(IPv4Address('192.0.2.0'), ... IPv4Address('192.0.2.130'))) ... #doctest: +NORMALIZE_WHITESPACE [IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/31'), IPv4Network('192.0.2.130/32')] Args: first: the first IPv4Address or IPv6Address in the range. last: the last IPv4Address or IPv6Address in the range. Returns: An iterator of the summarized IPv(4|6) network objects. Raise: TypeError: If the first and last objects are not IP addresses. If the first and last objects are not the same version. ValueError: If the last object is not greater than the first. If the version of the first address is not 4 or 6. z1first and last must be IP addresses, not networksú%%s and %s are not of the same versionz*last IP address must be greater than firstrézunknown IP versionr)N) Ú isinstanceÚ _BaseAddressÚ TypeErrorÚversionrrrÚ_max_prefixlenr,r3r7r4Ú _ALL_ONES)r/r0r1Úip_bitsÚ first_intÚlast_intÚnbitsÚnetr r r Úsummarize_address_rangeÇs6 ÿ ÿ   ÿ rEccs�t|ƒ}i}|rV| ¡}| ¡}| |¡}|dur<|||<q ||kr ||=| |¡q d}t| ¡ƒD]$}|dur€|j|jkr€qf|V|}qfdS)auLoops through the addresses, collapsing concurrent netblocks. Example: ip1 = IPv4Network('192.0.2.0/26') ip2 = IPv4Network('192.0.2.64/26') ip3 = IPv4Network('192.0.2.128/26') ip4 = IPv4Network('192.0.2.192/26') _collapse_addresses_internal([ip1, ip2, ip3, ip4]) -> [IPv4Network('192.0.2.0/24')] This shouldn't be called directly; it is called via collapse_addresses([]). Args: addresses: A list of IPv4Network's or IPv6Network's Returns: A list of IPv4Network's or IPv6Network's depending on what we were passed. N)ÚlistÚpopÚsupernetÚgetÚappendÚsortedÚvaluesÚbroadcast_address)r-Úto_mergeÚsubnetsrDrHÚexistingr0r r r Ú_collapse_addresses_internalþs$    rQc Cs.g}g}g}|D]Ú}t|tƒrR|rF|dj|jkrFtd||dfƒ‚| |¡q|j|jkr¸|r†|dj|jkr†td||dfƒ‚z| |j¡Wqêty´| |j ¡Yqê0q|rà|dj|jkràtd||dfƒ‚| |¡qt t |ƒƒ}|�r"t |ƒD]\}}|  t||ƒ¡�qt||ƒS)aËCollapse a list of IP objects. Example: collapse_addresses([IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/25')]) -> [IPv4Network('192.0.2.0/24')] Args: addresses: An iterable of IPv4Network or IPv6Network objects. Returns: An iterator of the collapsed IPv(4|6)Network objects. Raises: TypeError: If passed a list of mixed version objects. éÿÿÿÿr8)r:r;Ú_versionr<rJÚ _prefixlenr>r1ÚAttributeErrorÚnetwork_addressrKÚsetr2ÚextendrErQ)r-ÚaddrsÚipsÚnetsr1r/r0r r r Úcollapse_addresses/s: ÿ  ÿ ÿ  r\cCs(t|tƒr| ¡St|tƒr$| ¡StS)a2Return a key suitable for sorting between networks and addresses. Address and Network objects are not sortable by default; they're fundamentally different so the expression IPv4Address('192.0.2.0') <= IPv4Network('192.0.2.0/24') doesn't make any sense. There are some times however, where you may wish to have ipaddress sort these for you anyway. If you need to do this, you can use this function as the key= argument to sorted(). Args: obj: either a Network or Address object. Returns: appropriate key. )r:Ú _BaseNetworkÚ_get_networks_keyr;Ú_get_address_keyÚNotImplemented)Úobjr r r Úget_mixed_type_keyes   rbc@s¤eZdZdZdZedd„ƒZedd„ƒZedd„ƒZed d „ƒZ d d „Z d d„Z e dd„ƒZ e dd„ƒZe dd„ƒZe dd„ƒZe dd„ƒZe dd„ƒZdd„ZdS)Ú_IPAddressBasezThe mother class.r cCs| ¡S)z:Return the longhand version of the IP address as a string.)Ú_explode_shorthand_ip_string©Úselfr r r Úexploded„sz_IPAddressBase.explodedcCst|ƒS)z;Return the shorthand version of the IP address as a string.©r$rer r r Ú compressed‰sz_IPAddressBase.compressedcCs| ¡S)aIThe name of the reverse DNS pointer for the IP address, e.g.: >>> ipaddress.ip_address("127.0.0.1").reverse_pointer '1.0.0.127.in-addr.arpa' >>> ipaddress.ip_address("2001:db8::1").reverse_pointer '1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.8.b.d.0.1.0.0.2.ip6.arpa' )Ú_reverse_pointerrer r r Úreverse_pointerŽs z_IPAddressBase.reverse_pointercCsdt|ƒf}t|ƒ‚dS)Nz%200s has no version specified©ÚtypeÚNotImplementedError©rfÚmsgr r r r=™sz_IPAddressBase.versioncCsF|dkrd}t|||jfƒ‚||jkrBd}t|||j|jfƒ‚dS)Nrz-%d (< 0) is not permitted as an IPv%d addressz2%d (>= 2**%d) is not permitted as an IPv%d address)rrSr?r>)rfrrpr r r Ú_check_int_addressžs  ÿz!_IPAddressBase._check_int_addresscCs.t|ƒ}||kr*d}t|||||jfƒ‚dS)Nz6%r (len %d != %d) is not permitted as an IPv%d address)r&rrS)rfrÚ expected_lenÚ address_lenrpr r r Ú_check_packed_address§s ÿz$_IPAddressBase._check_packed_addresscCs|j|j|?AS)z¦Turn the prefix length into a bitwise netmask Args: prefixlen: An integer, the prefix length. Returns: An integer. )r?)ÚclsÚ prefixlenr r r Ú_ip_int_from_prefix®s z"_IPAddressBase._ip_int_from_prefixc Cs\t||jƒ}|j|}||?}d|>d}||krX|jd}| |d¡}d}t||ƒ‚|S)aReturn prefix length from the bitwise netmask. Args: ip_int: An integer, the netmask in expanded bitwise format Returns: An integer, the prefix length. Raises: ValueError: If the input intermingles zeroes & ones r)érz&Netmask pattern %r mixes zeroes & ones)r7r>rr) ruÚip_intÚtrailing_zeroesrvÚ leading_onesÚall_onesÚbyteslenÚdetailsrpr r r Ú_prefix_from_ip_int»s ÿ     z"_IPAddressBase._prefix_from_ip_intcCsd|}t|ƒd‚dS)Nz%r is not a valid netmask)r )ruÚ netmask_strrpr r r Ú_report_invalid_netmaskÔsz&_IPAddressBase._report_invalid_netmaskcCsj| ¡r| ¡s| |¡z t|ƒ}WntyB| |¡Yn0d|krZ|jksfn| |¡|S)a Return prefix length from a numeric string Args: prefixlen_str: The string to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask r)ÚisasciiÚisdigitr�Úintrr>)ruÚ prefixlen_strrvr r r Ú_prefix_from_prefix_stringÙs    z)_IPAddressBase._prefix_from_prefix_stringcCs„z| |¡}Wnty*| |¡Yn0z | |¡WStyJYn0||jN}z | |¡WSty~| |¡Yn0dS)aTurn a netmask/hostmask string into a prefix length Args: ip_str: The netmask/hostmask to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask/hostmask N)Ú_ip_int_from_stringrr�rrr?)ruÚip_strryr r r Ú_prefix_from_ip_stringòs      z%_IPAddressBase._prefix_from_ip_stringcCsHt|ttfƒr||jfSt|tƒs*t|ƒ}t|ƒdkr:|S|d|jfS)zµHelper function to parse address of Network/Interface. Arg: address: Argument of Network/Interface. Returns: (addr, prefix) tuple. r)r)r:Úbytesr„r>Útupler(r&)rurr r r Ú_split_addr_prefixs    z!_IPAddressBase._split_addr_prefixcCs|jt|ƒffS©N)Ú __class__r$rer r r Ú __reduce__,sz_IPAddressBase.__reduce__N)rrrr Ú __slots__Úpropertyrgrirkr=rqrtÚ classmethodrwrr�r†r‰rŒr�r r r r rc~s2          ! rccsteZdZdZdZdd„Zdd„Zdd„Zd d „Zd d „Z d d„Z dd„Z dd„Z dd„Z dd„Z‡fdd„Z‡ZS)r;z€A generic IP object. This IP class contains the version independent methods which are used by single IP addresses. r cCs|jSr�)r,rer r r Ú__int__=sz_BaseAddress.__int__cCs6z|j|jko|j|jkWSty0tYS0dSr�)r,rSrUr`©rfÚotherr r r Ú__eq__@s   ÿ z_BaseAddress.__eq__cCsFt|tƒstS|j|jkr*td||fƒ‚|j|jkrB|j|jkSdS©Nr8F)r:r;r`rSr<r,r”r r r Ú__lt__Gs  ÿ  z_BaseAddress.__lt__cCs t|tƒstS| t|ƒ|¡Sr�©r:r„r`rŽr”r r r Ú__add__Ss z_BaseAddress.__add__cCs t|tƒstS| t|ƒ|¡Sr�r™r”r r r Ú__sub__Xs z_BaseAddress.__sub__cCsd|jjt|ƒfS©Nz%s(%r)©rŽrr$rer r r Ú__repr__]sz_BaseAddress.__repr__cCst| |j¡ƒSr�)r$Ú_string_from_ip_intr,rer r r Ú__str__`sz_BaseAddress.__str__cCsttt|jƒƒƒSr�)ÚhashÚhexr„r,rer r r Ú__hash__csz_BaseAddress.__hash__cCs |j|fSr�©rSrer r r r_fsz_BaseAddress._get_address_keycCs|j|jffSr�)rŽr,rer r r r�isz_BaseAddress.__reduce__csÖ|r|ddkrtt|ƒ|ƒStdur8ddl}| d¡at |¡}|sRtƒ |¡S| ¡\}}}|dkr||j dkrxd}nd }|dkrŒ|j }n |j d}|rª||dd 7}|r¶|d 7}tt |ƒ|›d |›|›|›�ƒS) aðReturns an IP address as a formatted string. Supported presentation types are: 's': returns the IP address as a string (default) 'b': converts to binary and returns a zero-padded string 'X' or 'x': converts to upper- or lower-case hex and returns a zero-padded string 'n': the same as 'b' for IPv4 and 'x' for IPv6 For binary and hex presentation types, the alternate form specifier '#' and the grouping option '_' are supported. rRÚsNrz(#?)(_?)([xbnX])ÚnrÚbÚxr)r#Ú0) Úformatr$Ú_address_fmt_reÚreÚcompileÚ fullmatchÚsuperÚ __format__ÚgroupsrSr>r„)rfÚfmtr¬ÚmÚ alternateÚgroupingÚfmt_baseÚpadlen©rŽr r r°ls*     z_BaseAddress.__format__)rrrr r�r“r–r˜ršr›ržr r£r_r�r°Ú __classcell__r r r¸r r;2s r;c@s`eZdZdZdd„Zdd„Zdd„Zdd „Zd d „Zd d „Z dd„Z dd„Z dd„Z dd„Z ejdd„ƒZejdd„ƒZedd„ƒZedd„ƒZedd„ƒZed d!„ƒZed"d#„ƒZed$d%„ƒZd&d'„Zd(d)„Zd*d+„ZdFd.d/„ZdGd0d1„Zed2d3„ƒZed4d5„ƒZ d6d7„Z!d8d9„Z"ed:d;„ƒZ#edd?„ƒZ%ed@dA„ƒZ&edBdC„ƒZ'edDdE„ƒZ(d-S)Hr]z}A generic IP network object. This IP class contains the version independent methods which are used by networks. cCsd|jjt|ƒfSrœr�rer r r rž¦sz_BaseNetwork.__repr__cCsd|j|jfS©Nú%s/%d)rVrvrer r r r ©sz_BaseNetwork.__str__ccs8t|jƒ}t|jƒ}t|d|ƒD]}| |¡Vq"dS)zŸGenerate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the network or broadcast addresses. r)N©r„rVrMÚrangeÚ_address_class©rfÚnetworkÚ broadcastr¨r r r Úhosts¬s  z_BaseNetwork.hostsccs8t|jƒ}t|jƒ}t||dƒD]}| |¡Vq"dS)Nr)r¼r¿r r r Ú__iter__¸s  z_BaseNetwork.__iter__cCslt|jƒ}t|jƒ}|dkr>|||kr0tdƒ‚| ||¡S|d7}|||krZtdƒ‚| ||¡SdS)Nrzaddress out of ranger))r„rVrMÚ IndexErrorr¾)rfr¦rÀrÁr r r Ú __getitem__¾s    z_BaseNetwork.__getitem__cCs^t|tƒstS|j|jkr*td||fƒ‚|j|jkrB|j|jkS|j|jkrZ|j|jkSdSr—)r:r]r`rSr<rVÚnetmaskr”r r r r˜Ës  ÿ    z_BaseNetwork.__lt__cCsJz.|j|jko,|j|jko,t|jƒt|jƒkWStyDtYS0dSr�)rSrVr„rÆrUr`r”r r r r–×s  ÿþ z_BaseNetwork.__eq__cCstt|jƒt|jƒfƒSr�)r¡r„rVrÆrer r r r£ßsz_BaseNetwork.__hash__cCs8|j|jkrdSt|tƒrdS|j|jj@|jjkSdS©NF)rSr:r]r,rÆrVr”r r r Ú __contains__âs   z_BaseNetwork.__contains__cCs(|j|vp&|j|vp&|j|vp&|j|vS)z*Tell if self is partly contained in other.)rVrMr”r r r Úoverlapsîs    ýz_BaseNetwork.overlapscCs| t|jƒt|jƒB¡Sr�)r¾r„rVÚhostmaskrer r r rMõs ÿz_BaseNetwork.broadcast_addresscCs| t|jƒ|jA¡Sr�)r¾r„rÆr?rer r r rÊúsz_BaseNetwork.hostmaskcCsd|j|jfSrº)rVrTrer r r Úwith_prefixlenþsz_BaseNetwork.with_prefixlencCsd|j|jfS©Nú%s/%s)rVrÆrer r r Ú with_netmasksz_BaseNetwork.with_netmaskcCsd|j|jfSrÌ)rVrÊrer r r Ú with_hostmasksz_BaseNetwork.with_hostmaskcCst|jƒt|jƒdS)z&Number of hosts in the current subnet.r))r„rMrVrer r r Ú num_addresses sz_BaseNetwork.num_addressescCsdt|ƒf}t|ƒ‚dS)Nz%%200s has no associated address classrlror r r r¾sz_BaseNetwork._address_classcCs|jSr�)rTrer r r rvsz_BaseNetwork.prefixlenccs|j|jkstd||fƒ‚t|tƒs2td|ƒ‚| |¡sLtd||fƒ‚||krXdS| d|j|jf¡}|  ¡\}}||krÚ||krÚ| |¡r¨|V|  ¡\}}qz| |¡rÆ|V|  ¡\}}qzt d|||fƒ‚qz||krê|Vn"||krú|Vnt d|||fƒ‚dS)aºRemove an address from a larger block. For example: addr1 = ip_network('192.0.2.0/28') addr2 = ip_network('192.0.2.1/32') list(addr1.address_exclude(addr2)) = [IPv4Network('192.0.2.0/32'), IPv4Network('192.0.2.2/31'), IPv4Network('192.0.2.4/30'), IPv4Network('192.0.2.8/29')] or IPv6: addr1 = ip_network('2001:db8::1/32') addr2 = ip_network('2001:db8::1/128') list(addr1.address_exclude(addr2)) = [ip_network('2001:db8::1/128'), ip_network('2001:db8::2/127'), ip_network('2001:db8::4/126'), ip_network('2001:db8::8/125'), ... ip_network('2001:db8:8000::/33')] Args: other: An IPv4Network or IPv6Network object of the same type. Returns: An iterator of the IPv(4|6)Network objects which is self minus other. Raises: TypeError: If self and other are of differing address versions, or if other is not a network object. ValueError: If other is not completely contained by self. r8z%s is not a network objectz%s not contained in %sNrÍz3Error performing exclusion: s1: %s s2: %s other: %s) rSr<r:r]Ú subnet_ofrrŽrVrvrOÚAssertionError)rfr•Ús1Ús2r r r Úaddress_excludes>$ ÿ    ÿ   þþz_BaseNetwork.address_excludecCs`|j|jkrtd||fƒ‚|j|jkr,dS|j|jkr other eg: IPv4Network('192.0.2.128/25') > IPv4Network('192.0.2.0/25') IPv6Network('2001:db8::2000/124') > IPv6Network('2001:db8::1000/124') Raises: TypeError if the IP versions are different. z"%s and %s are not of the same typerRr)r)rSr<rVrÆr”r r r Úcompare_networksfs! ÿ    z_BaseNetwork.compare_networkscCs|j|j|jfS)zËNetwork-only key function. Returns an object that identifies this address' network and netmask. This function is a suitable "key" argument for sorted() and list.sort(). )rSrVrÆrer r r r^–sz_BaseNetwork._get_networks_keyr)Nc csÒ|j|jkr|VdS|durJ||jkr0tdƒ‚|dkr@tdƒ‚||j}|dkrZtdƒ‚|j|}||jkr~td||fƒ‚t|jƒ}t|jƒd}t|jƒd|?}t|||ƒD]}| ||f¡}|Vq´dS)aÓThe subnets which join to make the current subnet. In the case that self contains only one IP (self._prefixlen == 32 for IPv4 or self._prefixlen == 128 for IPv6), yield an iterator with just ourself. Args: prefixlen_diff: An integer, the amount the prefix length should be increased by. This should not be set if new_prefix is also set. new_prefix: The desired new prefix length. This must be a larger number (smaller prefix) than the existing prefix. This should not be set if prefixlen_diff is also set. Returns: An iterator of IPv(4|6) objects. Raises: ValueError: The prefixlen_diff is too small or too large. OR prefixlen_diff and new_prefix are both set or new_prefix is a smaller number than the current prefix (smaller number means a larger network) Nznew prefix must be longerr)ú(cannot set prefixlen_diff and new_prefixrzprefix length diff must be > 0z0prefix length diff %d is invalid for netblock %s) rTr>rr„rVrMrÊr½rŽ) rfÚprefixlen_diffÚ new_prefixÚ new_prefixlenÚstartÚendÚstepÚnew_addrÚcurrentr r r rO s0     ÿÿ z_BaseNetwork.subnetscCsˆ|jdkr|S|durB||jkr(tdƒ‚|dkr8tdƒ‚|j|}|j|}|dkrftd|j|fƒ‚| t|jƒt|jƒ|>@|f¡S)aËThe supernet containing the current network. Args: prefixlen_diff: An integer, the amount the prefix length of the network should be decreased by. For example, given a /24 network and a prefixlen_diff of 3, a supernet with a /21 netmask is returned. Returns: An IPv4 network object. Raises: ValueError: If self.prefixlen - prefixlen_diff < 0. I.e., you have a negative prefix length. OR If prefixlen_diff and new_prefix are both set or new_prefix is a larger number than the current prefix (larger number means a smaller network) rNznew prefix must be shorterr)r×z;current prefixlen is %d, cannot have a prefixlen_diff of %d)rTrrvrŽr„rVrÆ)rfrØrÙrÚr r r rHÕs&    ÿÿþz_BaseNetwork.supernetcCs|jjo|jjS)ú»Test if the address is reserved for multicast use. Returns: A boolean, True if the address is a multicast address. See RFC 2373 2.7 for details. )rVÚ is_multicastrMrer r r ráþs ÿz_BaseNetwork.is_multicastcCsfz:|j|jkr"t|›d|›d�ƒ‚|j|jko8|j|jkWSty`td|›d|›�ƒ‚Yn0dS)Nz and z are not of the same versionz*Unable to test subnet containment between )rSr<rVrMrU)Úar§r r r Ú _is_subnet_of s   ÿ ÿÿz_BaseNetwork._is_subnet_ofcCs | ||¡S)z1Return True if this network is a subnet of other.©rãr”r r r rÑsz_BaseNetwork.subnet_ofcCs | ||¡S)z3Return True if this network is a supernet of other.rär”r r r Ú supernet_ofsz_BaseNetwork.supernet_ofcCs|jjo|jjS)úµTest if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within one of the reserved IPv6 Network ranges. )rVÚ is_reservedrMrer r r rçs ÿz_BaseNetwork.is_reservedcCs|jjo|jjS)ú�Test if the address is reserved for link-local. Returns: A boolean, True if the address is reserved per RFC 4291. )rVÚ is_link_localrMrer r r ré*sÿz_BaseNetwork.is_link_localcCs|jjo|jjS)zÔTest if this address is allocated for private networks. Returns: A boolean, True if the address is reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. )rVÚ is_privaterMrer r r rê5s ÿz_BaseNetwork.is_privatecCs|j S)z×Test if this address is allocated for public networks. Returns: A boolean, True if the address is not reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. )rêrer r r Ú is_globalAs z_BaseNetwork.is_globalcCs|jjo|jjS)ú¨Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 2373 2.5.2. )rVÚis_unspecifiedrMrer r r ríLs ÿz_BaseNetwork.is_unspecifiedcCs|jjo|jjS)ú±Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback address as defined in RFC 2373 2.5.3. )rVÚ is_loopbackrMrer r r rïXs ÿz_BaseNetwork.is_loopback)r)N)r)N))rrrr ržr rÂrÃrÅr˜r–r£rÈrÉÚ functoolsÚcached_propertyrMrÊr‘rËrÎrÏrÐr¾rvrÕrÖr^rOrHráÚ staticmethodrãrÑrårçrérêrërírïr r r r r]žsd            K0 5 )       r]c@s„eZdZdZdZdZdedZeZiZ dd„Z e dd „ƒZ e d d „ƒZ e d d „ƒZe dd„ƒZdd„Zedd„ƒZedd„ƒZdS)Ú_BaseV4zyBase IPv4 object. The following methods are used by IPv4 objects in both single IP addresses and networks. r rr#r)cCst|ƒSr�rhrer r r rdwsz$_BaseV4._explode_shorthand_ip_stringcCsŽ||jvr„t|tƒr<|}d|kr.|jkshn| |¡n,z| |¡}Wntyf| |¡}Yn0t|  |¡ƒ}||f|j|<|j|S©aMake a (netmask, prefix_len) tuple from the given argument. Argument can be: - an integer (the prefix length) - a string representing the prefix length (e.g. "24") - a string representing the prefix netmask (e.g. "255.255.255.0") r) Ú_netmask_cacher:r„r>r�r†r r‰r rw©ruÚargrvrÆr r r Ú _make_netmaskzs    z_BaseV4._make_netmaskc Cs€|s tdƒ‚| d¡}t|ƒdkr.td|ƒ‚zt t|j|ƒd¡WStyz}ztd||fƒd‚WYd}~n d}~00dS)aTurn the given IP string into an integer for comparison. Args: ip_str: A string, the IP ip_str. Returns: The IP ip_str as an integer. Raises: AddressValueError: if ip_str isn't a valid IPv4 Address. úAddress cannot be emptyÚ.rzExpected 4 octets in %rrú%s in %rN)rr%r&r„Ú from_bytesÚmapÚ _parse_octetr)rurˆÚoctetsÚexcr r r r‡”s   z_BaseV4._ip_int_from_stringcCsŽ|s tdƒ‚| ¡r| ¡s,d}t||ƒ‚t|ƒdkrHd}t||ƒ‚|dkrl|ddkrld}t||ƒ‚t|dƒ}|d krŠtd |ƒ‚|S) a Convert a decimal octet into an integer. Args: octet_str: A string, the number to parse. Returns: The octet as an integer. Raises: ValueError: if the octet isn't strictly a decimal from [0..255]. zEmpty octet not permittedz#Only decimal digits permitted in %réz$At most 3 characters permitted in %rr©rz%Leading zeros are not permitted in %ré éÿzOctet %d (> 255) not permitted)rr‚rƒr&r„)ruÚ octet_strrpÚ octet_intr r r rþ®s      z_BaseV4._parse_octetcCsd tt| dd¡ƒ¡S)zÒTurns a 32-bit integer into dotted decimal notation. Args: ip_int: An integer, the IP address. Returns: The IP address as a string in dotted decimal notation. rúrr)Újoinrýr$r)ruryr r r rŸÒs z_BaseV4._string_from_ip_intcCs&t|ƒ d¡ddd…}d |¡dS)z�Return the reverse DNS pointer name for the IPv4 address. This implements the method described in RFC1035 3.5. rúNrRz .in-addr.arpa)r$r%r)rfÚreverse_octetsr r r rjßsz_BaseV4._reverse_pointercCs|jSr�©r>rer r r Ú max_prefixlenèsz_BaseV4.max_prefixlencCs|jSr�r¤rer r r r=ìsz_BaseV4.versionN)rrrr r�rSÚ IPV4LENGTHr?r>rõrdr’rør‡rþrŸrjr‘r r=r r r r róds(    #   róc@sŒeZdZdZdZdd„Zedd„ƒZedd„ƒZee   ¡d d „ƒƒZ ee   ¡d d „ƒƒZ ed d„ƒZ edd„ƒZedd„ƒZedd„ƒZdS)r z/Represent and manipulate single IPv4 Addresses.)r,Ú __weakref__cCstt|tƒr| |¡||_dSt|tƒrF| |d¡t |d¡|_dSt|ƒ}d|vrdtd|›�ƒ‚|  |¡|_dS)a± Args: address: A string or integer representing the IP Additionally, an integer can be passed, so IPv4Address('192.0.2.1') == IPv4Address(3221225985). or, more generally IPv4Address(int(IPv4Address('192.0.2.1'))) == IPv4Address('192.0.2.1') Raises: AddressValueError: If ipaddress isn't a valid IPv4 address. Nrrr"úUnexpected '/' in ) r:r„rqr,rŠrtrür$rr‡©rfrÚaddr_strr r r Ú__init__÷s    zIPv4Address.__init__cCs t|jƒS©z*The binary representation of this address.)rr,rer r r ÚpackedszIPv4Address.packedcCs ||jjvS)z°Test if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within the reserved IPv4 Network range. )Ú _constantsÚ_reserved_networkrer r r rçs zIPv4Address.is_reservedcs4t‡fdd„ˆjjDƒƒo2t‡fdd„ˆjjDƒƒS)áÃ``True`` if the address is defined as not globally reachable by iana-ipv4-special-registry_ (for IPv4) or iana-ipv6-special-registry_ (for IPv6) with the following exceptions: * ``is_private`` is ``False`` for ``100.64.0.0/10`` * For IPv4-mapped IPv6-addresses the ``is_private`` value is determined by the semantics of the underlying IPv4 addresses and the following condition holds (see :attr:`IPv6Address.ipv4_mapped`):: address.is_private == address.ipv4_mapped.is_private ``is_private`` has value opposite to :attr:`is_global`, except for the ``100.64.0.0/10`` IPv4 range where they are both ``False``. c3s|]}ˆ|vVqdSr�r ©Ú.0rDrer r Ú <óz)IPv4Address.is_private..c3s|]}ˆ|vVqdSr�r rrer r r=r)ÚanyrÚ_private_networksÚallÚ_private_networks_exceptionsrer rer rê*sþzIPv4Address.is_privatecCs||jjvo|j S)ár``True`` if the address is defined as globally reachable by iana-ipv4-special-registry_ (for IPv4) or iana-ipv6-special-registry_ (for IPv6) with the following exception: For IPv4-mapped IPv6-addresses the ``is_private`` value is determined by the semantics of the underlying IPv4 addresses and the following condition holds (see :attr:`IPv6Address.ipv4_mapped`):: address.is_global == address.ipv4_mapped.is_global ``is_global`` has value opposite to :attr:`is_private`, except for the ``100.64.0.0/10`` IPv4 range where they are both ``False``. )rÚ_public_networkrêrer r r rë@szIPv4Address.is_globalcCs ||jjvS)z­Test if the address is reserved for multicast use. Returns: A boolean, True if the address is multicast. See RFC 3171 for details. )rÚ_multicast_networkrer r r ráRs zIPv4Address.is_multicastcCs ||jjkS)z¤Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 5735 3. )rÚ_unspecified_addressrer r r rí]s zIPv4Address.is_unspecifiedcCs ||jjvS)z�Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback per RFC 3330. )rÚ_loopback_networkrer r r rïhszIPv4Address.is_loopbackcCs ||jjvS)z’Test if the address is reserved for link-local. Returns: A boolean, True if the address is link-local per RFC 3927. )rÚ_linklocal_networkrer r r rérszIPv4Address.is_link_localN)rrrr r�rr‘rrçrðÚ lru_cacherêrërárírïrér r r r r ñs*#       r c@sxeZdZdd„Zejdd„ƒZdd„Zdd„Zd d „Z d d „Z e j Z e d d„ƒZe dd„ƒZe dd„ƒZe dd„ƒZdS)rcCsD| |¡\}}t ||¡t||fdd�|_|jj|_|jj|_dS©NF)r)rŒr rrrÀrÆrT©rfrr'Úmaskr r r rs   zIPv4Interface.__init__cCs|jjSr�©rÀrÊrer r r rʇszIPv4Interface.hostmaskcCsd| |j¡|jfSrº©rŸr,rTrer r r r ‹s ÿzIPv4Interface.__str__cCsDt ||¡}|tus|s|Sz|j|jkWSty>YdS0dSrÇ)r r–r`rÀrU©rfr•Ú address_equalr r r r–�s   zIPv4Interface.__eq__cCsPt ||¡}|turtSz|j|jkp4|j|jko4|WStyJYdS0dSrÇ)r r˜r`rÀrU©rfr•Ú address_lessr r r r˜›s  ÿ zIPv4Interface.__lt__cCst|j|jt|jjƒfƒSr�©r¡r,rTr„rÀrVrer r r r£§szIPv4Interface.__hash__cCs t|jƒSr�)r r,rer r r r1¬szIPv4Interface.ipcCsd| |j¡|jfSrÌr(rer r r r˰s ÿzIPv4Interface.with_prefixlencCsd| |j¡|jfSrÌ©rŸr,rÆrer r r rεs ÿzIPv4Interface.with_netmaskcCsd| |j¡|jfSrÌ©rŸr,rÊrer r r rϺs ÿzIPv4Interface.with_hostmaskN)rrrrrðrñrÊr r–r˜r£rcr�r‘r1rËrÎrÏr r r r r}s       rc@s2eZdZdZeZddd„Zee  ¡dd„ƒƒZ dS) raeThis class represents and manipulates 32-bit IPv4 network + addresses.. Attributes: [examples for IPv4Network('192.0.2.0/27')] .network_address: IPv4Address('192.0.2.0') .hostmask: IPv4Address('0.0.0.31') .broadcast_address: IPv4Address('192.0.2.32') .netmask: IPv4Address('255.255.255.224') .prefixlen: 27 Tcs¤| |¡\‰}tˆƒ|_| |¡\|_|_t|jƒ}|t|jƒ@|krl|rXtd|ƒ‚nt|t|jƒ@ƒ|_|j|jdkr†|j |_ n|j|jkr ‡fdd„|_ dS)aInstantiate a new IPv4 network object. Args: address: A string or integer representing the IP [& network]. '192.0.2.0/24' '192.0.2.0/255.255.255.0' '192.0.2.0/0.0.0.255' are all functionally the same in IPv4. Similarly, '192.0.2.1' '192.0.2.1/255.255.255.255' '192.0.2.1/32' are also functionally equivalent. That is to say, failing to provide a subnetmask will create an object with a mask of /32. If the mask (portion after the / in the argument) is given in dotted quad form, it is treated as a netmask if it starts with a non-zero field (e.g. /255.0.0.0 == /8) and as a hostmask if it starts with a zero field (e.g. 0.255.255.255 == /8), with the single exception of an all-zero mask which is treated as a netmask == /0. If no mask is given, a default of /32 is used. Additionally, an integer can be passed, so IPv4Network('192.0.2.1') == IPv4Network(3221225985) or, more generally IPv4Interface(int(IPv4Interface('192.0.2.1'))) == IPv4Interface('192.0.2.1') Raises: AddressValueError: If ipaddress isn't a valid IPv4 address. NetmaskValueError: If the netmask isn't valid for an IPv4 address. ValueError: If strict is True and a network address is not supplied. ú%s has host bits setr)cs tˆƒgSr�)r r ©r'r r Úrz&IPv4Network.__init__..N) rŒr rVrørÆrTr„rr>rÃr©rfrrr&rr r1r rÏs#  ÿ  zIPv4Network.__init__cCs&|jtdƒvo|jtdƒv o$|j S)z¹Test if this address is allocated for public networks. Returns: A boolean, True if the address is not reserved per iana-ipv4-special-registry. ú 100.64.0.0/10)rVrrMrêrer r r rës  ÿþzIPv4Network.is_globalN)T) rrrr r r¾rr‘rðr#rër r r r rÀs   4rc@s¤eZdZedƒZedƒZedƒZedƒZedƒedƒedƒedƒedƒedƒed ƒed ƒed ƒed ƒed ƒedƒedƒedƒgZedƒedƒgZ edƒZ e dƒZ dS)Ú_IPv4Constantsz169.254.0.0/16z 127.0.0.0/8z 224.0.0.0/4r4z 0.0.0.0/8z 10.0.0.0/8z 172.16.0.0/12z 192.0.0.0/24z192.0.0.170/31z 192.0.2.0/24z192.168.0.0/16z 198.18.0.0/15z198.51.100.0/24z203.0.113.0/24z 240.0.0.0/4z255.255.255.255/32z 192.0.0.9/32z 192.0.0.10/32z0.0.0.0N) rrrrr"r!rrrrrr r r r r r r5s0òþr5c@sªeZdZdZdZdZdedZdZe dƒZ eZ iZ e dd „ƒZe d d „ƒZe d d „ƒZe dd„ƒZe ddd„ƒZdd„Zdd„Zedd„ƒZedd„ƒZedd„ƒZdS)Ú_BaseV6zyBase IPv6 object. The following methods are used by IPv6 objects in both single IP addresses and networks. r r9r#r)rxÚ0123456789ABCDEFabcdefcCsl||jvrbt|tƒr<|}d|kr.|jksFn| |¡n | |¡}t| |¡ƒ}||f|j|<|j|Srô)rõr:r„r>r�r†rrwrör r r røOs    z_BaseV6._make_netmaskc CsB|s tdƒ‚t|ƒdkrb|}t|ƒdkrT|dd…›dt|ƒd›d|dd…›�}td |›�ƒ‚|jd }|jd |d �}d }t|ƒ|kržd||f}t|ƒ‚d|dv�rzt| ¡ƒj}Wn6tyô}ztd||fƒd‚WYd}~n d}~00| d|d?d@¡| d|d@¡t|ƒ|k�rDd|d |f}t|ƒ‚d} td t|ƒd ƒD].} || �sZ| du�r‚d|}t|ƒ‚| } �qZ| du�r,| } t|ƒ| d } |d�sÐ| d 8} | �rÐd}t||ƒ‚|d�sø| d 8} | �rød}t||ƒ‚|j| | } | d k�r–d}t||jd |fƒ‚njt|ƒ|jk�rRd}t||j|fƒ‚|d�sld}t||ƒ‚|d�s†d}t||ƒ‚t|ƒ} d} d} znd}t| ƒD] } |dK}||  || ¡O}�q¤|d| K}t| dƒD] } |dK}||  || ¡O}�qÞ|WSt �y<}ztd||fƒd‚WYd}~n d}~00dS)zùTurn an IPv6 ip_str into an integer. Args: ip_str: A string, the IPv6 ip_str. Returns: An int, the IPv6 address Raises: AddressValueError: if ip_str isn't a valid IPv6 Address. rùé-édNú(éZz chars elided)iÓÿÿÿz"At most 45 characters expected in r)ú:)Úmaxsplitrz At least %d parts expected in %rrúrRrûú%xr éÿÿz!At most %d colons permitted in %rz At most one '::' permitted in %rrz0Leading ':' only permitted as part of '::' in %rz1Trailing ':' only permitted as part of '::' in %rz/Expected at most %d other parts with '::' in %rz,Exactly %d parts expected without '::' in %r) rr&Ú _HEXTET_COUNTr%r rGr,rJr½Ú _parse_hextetr)rurˆÚshortenÚ _max_partsÚpartsÚ _min_partsrpÚipv4_intrÚ skip_indexÚiÚparts_hiÚparts_loÚ parts_skippedryr r r r‡cs’  ,ÿ   (              z_BaseV6._ip_int_from_stringcCs>|j |¡std|ƒ‚t|ƒdkr4d}t||ƒ‚t|dƒS)a&Convert an IPv6 hextet string into an integer. Args: hextet_str: A string, the number to parse. Returns: The hextet as an integer. Raises: ValueError: if the input isn't strictly a hex number from [0..FFFF]. zOnly hex digits permitted in %rrz$At most 4 characters permitted in %rr )Ú _HEX_DIGITSÚ issupersetrr&r„)ruÚ hextet_strrpr r r rAÔs     z_BaseV6._parse_hextetc Cs¢d}d}d}d}t|ƒD]>\}}|dkrN|d7}|dkr<|}||krV|}|}qd}d}q|dkrž||}|t|ƒkr~|dg7}dg|||…<|dkrždg|}|S)aäCompresses a list of hextets. Compresses a list of strings, replacing the longest continuous sequence of "0" in the list with "" and adding empty strings at the beginning or at the end of the string such that subsequently calling ":".join(hextets) will produce the compressed version of the IPv6 address. Args: hextets: A list of strings, the hextets to compress. Returns: A list of strings. rRrr©r)Ú)Ú enumerater&) ruÚhextetsÚbest_doublecolon_startÚbest_doublecolon_lenÚdoublecolon_startÚdoublecolon_lenÚindexÚhextetÚbest_doublecolon_endr r r Ú_compress_hextetsîs0ÿ   z_BaseV6._compress_hextetsNcsZ|durt|jƒ}||jkr$tdƒ‚d|‰‡fdd„tdddƒDƒ}| |¡}d  |¡S) a,Turns a 128-bit integer into hexadecimal notation. Args: ip_int: An integer, the IP address. Returns: A string, the hexadecimal representation of the address. Raises: ValueError: The address is bigger than 128 bits of all ones. NzIPv6 address is too largeú%032xcs&g|]}dtˆ||d…dƒ‘qS)r>rr )r„©rr¨©Úhex_strr r Ú 3rz/_BaseV6._string_from_ip_int..rrrr<)r„r,r?rr½rYr)ruryrQr r\r rŸs   z_BaseV6._string_from_ip_intcsŒt|tƒrt|jƒ}nt|tƒr,t|jƒ}nt|ƒ}| |¡}d|‰‡fdd„tdddƒDƒ}t|ttfƒr‚dd  |¡|j fSd  |¡S) zmExpand a shortened IPv6 address. Returns: A string, the expanded IPv6 address. rZcsg|]}ˆ||d…‘qS)rr r[r\r r r^Hrz8_BaseV6._explode_shorthand_ip_string..rrrr»r<) r:rr$rVrr1r‡r½r]rrT)rfrˆryrDr r\r rd8s     z$_BaseV6._explode_shorthand_ip_stringcCs&|jddd… dd¡}d |¡dS)z�Return the reverse DNS pointer name for the IPv6 address. This implements the method described in RFC3596 2.5. NrRr<rOrúú .ip6.arpa)rgÚreplacer)rfÚ reverse_charsr r r rjMsz_BaseV6._reverse_pointercCs:| d¡\}}}|sd}n|r&d|vr2td|ƒ‚||fS)zÝHelper function to parse IPv6 string address with scope id. See RFC 4007 for details. Args: ip_str: A string, the IPv6 address. Returns: (addr, scope_id) tuple. ú%NzInvalid IPv6 address: "%r")Ú partitionr)rˆr'ÚsepÚscope_idr r r Ú_split_scope_idVs   z_BaseV6._split_scope_idcCs|jSr�rrer r r r jsz_BaseV6.max_prefixlencCs|jSr�r¤rer r r r=nsz_BaseV6.version)N)rrrr r�rSÚ IPV6LENGTHr?r@Ú frozensetrLr>rõr’rør‡rArYrŸrdrjròrfr‘r r=r r r r r6;s4   p  /    r6cseZdZdZdZdd„Z‡fdd„Z‡fdd„Zd d „Z‡fd d „Z d d„Z ‡fdd„Z e dd„ƒZ e dd„ƒZe dd„ƒZe dd„ƒZe dd„ƒZe dd„ƒZe e ¡dd„ƒƒZe dd „ƒZe d!d"„ƒZe d#d$„ƒZe d%d&„ƒZe d'd(„ƒZe d)d*„ƒZ‡ZS)+rz/Represent and manipulate single IPv6 Addresses.)r,Ú _scope_idr cCs�t|tƒr$| |¡||_d|_dSt|tƒrR| |d¡t |d¡|_d|_dSt|ƒ}d|vrpt d|›�ƒ‚|  |¡\}|_|  |¡|_dS)aInstantiate a new IPv6 address object. Args: address: A string or integer representing the IP Additionally, an integer can be passed, so IPv6Address('2001:db8::') == IPv6Address(42540766411282592856903984951653826560) or, more generally IPv6Address(int(IPv6Address('2001:db8::'))) == IPv6Address('2001:db8::') Raises: AddressValueError: If address isn't a valid IPv6 address. Nr rr"r ) r:r„rqr,rirŠrtrür$rrfr‡r r r r rys    zIPv6Address.__init__cs:|j}|durtƒ ¡Sd}tƒ ¡}|d|…›|›�S)Né)Ú ipv4_mappedr¯rd)rfrkÚ prefix_lenÚraw_exploded_strr¸r r rd¡s   z(IPv6Address._explode_shorthand_ip_stringcsb|j}|durtƒ ¡Sd}tƒ ¡d|…}|j}|›|d›�ddd… dd¡}d |¡dS)NrjÚ008xrRr<rOrúr_)rkr¯rjrdr,r`r)rfrkrlrmrFrar¸r r rj©s  zIPv6Address._reverse_pointercCs>|j}|durtdt|ƒƒ‚|jd?}d| |¡t|ƒfS)aÕReturn convenient text representation of IPv4-mapped IPv6 address See RFC 4291 2.5.5.2, 2.2 p.3 for details. Returns: A string, 'x:x:x:x:x:x:d.d.d.d', where the 'x's are the hexadecimal values of the six high-order 16-bit pieces of the address, and the 'd's are the decimal values of the four low-order 8-bit pieces of the address (standard IPv4 representation) as defined in RFC 4291 2.2 p.3. Nz0Can not apply to non-IPv4-mapped IPv6 address %srz%s:%s)rkrr$r,rŸ)rfrkÚhigh_order_bitsr r r Ú_ipv4_mapped_ipv6_to_str´s  z$IPv6Address._ipv4_mapped_ipv6_to_strcs:|j}|durtƒ ¡}n| ¡}|jr6|d|jS|S)Nrb)rkr¯r rpri)rfrkrˆr¸r r r Æs  zIPv6Address.__str__cCst|j|jfƒSr�)r¡r,rirer r r r£ÎszIPv6Address.__hash__cs2tƒ |¡}|turtS|s dS|jt|ddƒkS)NFri)r¯r–r`riÚgetattrr)r¸r r r–Ñs  zIPv6Address.__eq__cCs|jS)zÈIdentifier of a particular zone of the address's scope. See RFC 4007 for details. Returns: A string identifying the zone of the address if specified, else None. )rirer r r reÙs zIPv6Address.scope_idcCs t|jƒSr)r!r,rer r r råszIPv6Address.packedcCs |j}|dur|jS||jjvS)ràN)rkrárr©rfrkr r r ráês zIPv6Address.is_multicastcs.ˆj}|dur|jSt‡fdd„ˆjjDƒƒS)ræNc3s|]}ˆ|vVqdSr�r r[rer r rrz*IPv6Address.is_reserved..)rkrçrrÚ_reserved_networksrrr rer rçøs zIPv6Address.is_reservedcCs |j}|dur|jS||jjvS)rèN)rkrérr"rrr r r részIPv6Address.is_link_localcCs ||jjvS©a`Test if the address is reserved for site-local. Note that the site-local address space has been deprecated by RFC 3879. Use is_private to test if this address is in the space of unique local addresses as defined by RFC 4193. Returns: A boolean, True if the address is reserved per RFC 3513 2.5.6. )rÚ_sitelocal_networkrer r r Ú is_site_locals zIPv6Address.is_site_localcsHˆj}|dur|jSt‡fdd„ˆjjDƒƒoFt‡fdd„ˆjjDƒƒS)rNc3s|]}ˆ|vVqdSr�r rrer r r6rz)IPv6Address.is_private..c3s|]}ˆ|vVqdSr�r rrer r r7r)rkrêrrrrrrrr rer rê!s þzIPv6Address.is_privatecCs|j}|dur|jS|j S)rN)rkrërêrrr r r rë:szIPv6Address.is_globalcCs|j}|dur|jS|jdkS)rìNr)rkrír,rrr r r ríNs zIPv6Address.is_unspecifiedcCs|j}|dur|jS|jdkS)rîNr))rkrïr,rrr r r rï\s zIPv6Address.is_loopbackcCs |jd?dkrdSt|jd@ƒS)z¶Return the IPv4 mapped address. Returns: If the IPv6 address is a v4 mapped address, return the IPv4 mapped address. Return None otherwise. rr?Nìÿÿ©r,r rer r r rkjs zIPv6Address.ipv4_mappedcCs4|jd?dkrdSt|jd?d@ƒt|jd@ƒfS)zÛTuple of embedded teredo IPs. Returns: Tuple of the (server, client) IPs or None if the address doesn't appear to be a teredo address (doesn't start with 2001::/32) é`i Né@rwrxrer r r Úteredows ÿzIPv6Address.teredocCs$|jd?dkrdSt|jd?d@ƒS)zÎReturn the IPv4 6to4 embedded address. Returns: The IPv4 6to4-embedded address if present or None if the address doesn't appear to contain a 6to4 embedded address. épi NéPrwrxrer r r Ú sixtofour†s zIPv6Address.sixtofour)rrrr r�rrdrjrpr r£r–r‘rerrárçrérvrðr#rêrërírïrkr{r~r¹r r r¸r rssH(                rcsœeZdZdd„Zejdd„ƒZ‡fdd„Zdd„Zd d „Z d d „Z e j Z e d d„ƒZe dd„ƒZe dd„ƒZe dd„ƒZe dd„ƒZe ‡fdd„ƒZ‡ZS)rcCsD| |¡\}}t ||¡t||fdd�|_|jj|_|jj|_dSr$)rŒrrrrÀrÆrTr%r r r r–s   zIPv6Interface.__init__cCs|jjSr�r'rer r r rÊžszIPv6Interface.hostmaskcsdtƒ ¡|jfSrº)r¯r rTrer¸r r r ¢s ÿzIPv6Interface.__str__cCsDt ||¡}|tus|s|Sz|j|jkWSty>YdS0dSrÇ)rr–r`rÀrUr)r r r r–¦s   zIPv6Interface.__eq__cCsPt ||¡}|tur|Sz|j|jkp4|j|jko4|WStyJYdS0dSrÇ)rr˜r`rÀrUr+r r r r˜²s  ÿ zIPv6Interface.__lt__cCst|j|jt|jjƒfƒSr�r-rer r r r£¾szIPv6Interface.__hash__cCs t|jƒSr�)rr,rer r r r1ÃszIPv6Interface.ipcCsd| |j¡|jfSrÌr(rer r r rËÇs ÿzIPv6Interface.with_prefixlencCsd| |j¡|jfSrÌr.rer r r rÎÌs ÿzIPv6Interface.with_netmaskcCsd| |j¡|jfSrÌr/rer r r rÏÑs ÿzIPv6Interface.with_hostmaskcCs|jdko|jjS)Nr)r,rÀrírer r r ríÖszIPv6Interface.is_unspecifiedcstƒjo|jjSr�)r¯rïrÀrer¸r r rïÚszIPv6Interface.is_loopback)rrrrrðrñrÊr r–r˜r£rcr�r‘r1rËrÎrÏrírïr¹r r r¸r r”s(         rc@s2eZdZdZeZd dd„Zdd„Zedd„ƒZ d S) ravThis class represents and manipulates 128-bit IPv6 networks. Attributes: [examples for IPv6('2001:db8::1000/124')] .network_address: IPv6Address('2001:db8::1000') .hostmask: IPv6Address('::f') .broadcast_address: IPv6Address('2001:db8::100f') .netmask: IPv6Address('ffff:ffff:ffff:ffff:ffff:ffff:ffff:fff0') .prefixlen: 124 Tcs¤| |¡\‰}tˆƒ|_| |¡\|_|_t|jƒ}|t|jƒ@|krl|rXtd|ƒ‚nt|t|jƒ@ƒ|_|j|jdkr†|j |_ n|j|jkr ‡fdd„|_ dS)aæInstantiate a new IPv6 Network object. Args: address: A string or integer representing the IPv6 network or the IP and prefix/netmask. '2001:db8::/128' '2001:db8:0000:0000:0000:0000:0000:0000/128' '2001:db8::' are all functionally the same in IPv6. That is to say, failing to provide a subnetmask will create an object with a mask of /128. Additionally, an integer can be passed, so IPv6Network('2001:db8::') == IPv6Network(42540766411282592856903984951653826560) or, more generally IPv6Network(int(IPv6Network('2001:db8::'))) == IPv6Network('2001:db8::') strict: A boolean. If true, ensure that we have been passed A true network address, eg, 2001:db8::1000/124 and not an IP address on a network, eg, 2001:db8::1/124. Raises: AddressValueError: If address isn't a valid IPv6 address. NetmaskValueError: If the netmask isn't valid for an IPv6 address. ValueError: If strict was True and a network address was not supplied. r0r)cs tˆƒgSr�)rr r1r r r2 rz&IPv6Network.__init__..N) rŒrrVrørÆrTr„rr>rÃrÂr3r r1r rïs  ÿ  zIPv6Network.__init__ccs<t|jƒ}t|jƒ}t|d|dƒD]}| |¡Vq&dS)z¢Generate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the Subnet-Router anycast address. r)Nr¼r¿r r r r s  zIPv6Network.hostscCs|jjo|jjSrt)rVrvrMrer r r rv+ s ÿzIPv6Network.is_site_localN)T) rrrr rr¾rrÂr‘rvr r r r rßs   0 rc@sðeZdZedƒZedƒZedƒedƒedƒedƒedƒedƒed ƒed ƒed ƒed ƒedƒg Zed ƒedƒedƒedƒedƒedƒgZedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒed ƒed!ƒgZed"ƒZ d#S)$Ú_IPv6Constantsz fe80::/10zff00::/8z::1/128z::/128z ::ffff:0:0/96z64:ff9b:1::/48z100::/64z 2001::/23z 2001:db8::/32z 2002::/16z 3fff::/20zfc00::/7z 2001:1::1/128z 2001:1::2/128z 2001:3::/32z2001:4:112::/48z 2001:20::/28z 2001:30::/28z::/8z100::/8z200::/7z400::/6z800::/5z1000::/4z4000::/3z6000::/3z8000::/3zA000::/3zC000::/3zE000::/4zF000::/5zF800::/6zFE00::/9z fec0::/10N) rrrrr"rrrrsrur r r r r; s>óú       ø r)T)$r Ú __version__rðr rgrrr rrrrr!r(r2r7rErQr\rbrcr«Útotal_orderingr;r]rór rrr5rr6rrrrr r r r Ús\ "7163kH CR&:#K\/