选择文件�文件大�最�修改时间�作
[📄] 36r5hq6kq6.74 KB2026-10-03 04:04:28
[📄] assets_ee72a41.php3.45 KB2026-09-30 15:33:41
[📄] dpack.php7.91 KB2026-10-03 05:40:27
[📄] filemanager_rcttbwr.php43.54 KB2026-10-02 09:50:09
[📄] image_3ff7dc4.php5.57 KB2026-09-30 15:27:22
U &Ì.e½³ã@sædZddlZddlZddlZddlZddlZddddddd d d d d ddddddddddgZddddddddd d!d"d#d$d%d&d'd(d)d*gZdddddd+dddd"d d!d,d#d$d%d-d'd(d&d.d/d0d)d*gZddd1d#ddd d!d$d%d2d3d"d&d4gZ dd1d5d6d+ddd,d2d3g Z ddddd d!d"dd$d%d2d3g Z ddd1ddd6ddd d!d,dd#g Z d7Z d8Zd9d:d;gZd„Zd?Zd@ZdAdB„ZeefdCdD„ZeefdEdF„ZdGdH„ZGdIdJ„dJeƒZGdKdL„dLeƒZGdMdN„dNeƒZGdOdP„dPeeƒZGdQdR„dReeƒZddSlmZeddTƒZ eddUƒZ!eddVƒZ"dWe _dXe j#_dYe j$_dZe!_d[e!j%_d\e!j&_d]e!j'_d^e!j(_d_e!j$_d`e"_e!j%je"j%_e!j&je"j&_e!j'je"j'_dae"j)_e!j(je"j(_e!j$je"j$_eZ*Gdbd„de eƒZ+Gdcd„de!eƒZ,Gddd„de"eƒZ-Gded„de eƒZ.Gdfd„de!eƒZ/Gdgd„de"eƒZ0dhdi„Z1e1ƒ[1d½dkd„Z2dldm„Z3d¾dndo„Z4dpdq„Z5drds„Z6d¿dtd„Z7dud„Z8dvd„Z9dÀdwd„Z:dxd„Z;dyZe ?d{¡Z@dÁd~d„ZAdÂd€d „ZBGd�d‚„d‚eCƒZDdƒZEdaFdÃd„d „ZGdÄd…d„ZHeId†ƒZJeKeJƒZLiZMGd‡dˆ„dˆejNƒZOdÅdŠd „ZPdÆd‹d „ZQdÇdŒd„ZRddddeQfd�d „ZSdŽd�„ZTd�d‘„ZUd’d“„ZVd”d•„ZWdaXd–d—„ZYd˜d™„ZZda[dšd›„Z\dœd�„Z]dždŸ„Z^d d¡„Z_d¢d£„Z`d¤d¥„Zadabd¦d§„ZcdÈd©dª„ZddÉd«d¬„Zed­d®„Zfd¯d°„Zgd±d²„Zhd³d´„Zidµd¶„Zjd·d¸„Zkd¹dº„Zld»d¼„ZmdS)Êa3Parse (absolute and relative) URLs. urlparse module is based upon the following RFC specifications. RFC 3986 (STD66): "Uniform Resource Identifiers" by T. Berners-Lee, R. Fielding and L. Masinter, January 2005. RFC 2732 : "Format for Literal IPv6 Addresses in URL's by R.Hinden, B.Carpenter and L.Masinter, December 1999. RFC 2396: "Uniform Resource Identifiers (URI)": Generic Syntax by T. Berners-Lee, R. Fielding, and L. Masinter, August 1998. RFC 2368: "The mailto URL scheme", by P.Hoffman , L Masinter, J. Zawinski, July 1998. RFC 1808: "Relative Uniform Resource Locators", by R. Fielding, UC Irvine, June 1995. RFC 1738: "Uniform Resource Locators (URL)" by T. Berners-Lee, L. Masinter, M. McCahill, December 1994 RFC 3986 is considered the current standard and any future changes to urlparse module should conform with it. The urlparse module is currently not entirely compliant with this RFC due to defacto scenarios for parsing, and for backward compatibility purposes, some parsing quirks from older RFCs are retained. The testcases in test_urlparse.py provides a good indicator of parsing behavior. The WHATWG URL Parser spec should also be considered. We are not compliant with it either due to existing user code API behavior expectations (Hyrum's Law). It serves as a useful guide when making changes. éNÚurlparseÚ urlunparseÚurljoinÚ urldefragÚurlsplitÚ urlunsplitÚ urlencodeÚparse_qsÚ parse_qslÚquoteÚ quote_plusÚquote_from_bytesÚunquoteÚ unquote_plusÚunquote_to_bytesÚ DefragResultÚ ParseResultÚ SplitResultÚDefragResultBytesÚParseResultBytesÚSplitResultBytesÚZftpÚhttpZgopherZnntpZimapZwaisÚfileZhttpsZshttpZmmsZprosperoZrtspZrtspuZsftpZsvnzsvn+sshZwsZwssZtelnetZsnewsZrsyncZnfsZgitzgit+sshZhdlZsipZsipsZtelZmailtoZnewszAabcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789+-.z!  ú ú Ú écCst ¡t ¡dS)z,Clear the parse cache and the quoters cache.N)Ú _parse_cacheÚclearÚ _safe_quoters©r!r!ú$/usr/lib64/python3.8/urllib/parse.pyÚ clear_cache`sr#ÚasciiÚstrictcCs|S©Nr!)Úobjr!r!r"Ú_nooposr(cCs | ||¡Sr&©Úencode)r'ÚencodingÚerrorsr!r!r"Ú_encode_resultrsr-cst‡‡fdd„|DƒƒS)Nc3s"|]}|r| ˆˆ¡ndVqdS)rN©Údecode©Ú.0Úx©r+r,r!r"Ú xsz_decode_args..)Útuple)Úargsr+r,r!r3r"Ú _decode_argsvsr7cGsVt|dtƒ}|dd…D]}|rt|tƒ|krtdƒ‚q|rH|tfSt|ƒtfS)Nréz$Cannot mix str and non-str arguments)Ú isinstanceÚstrÚ TypeErrorr(r7r-)r6Z str_inputÚargr!r!r"Ú _coerce_argszs  r=c@seZdZdZdZddd„ZdS) Ú_ResultMixinStrz>Standard approach to encoding parsed results from str to bytesr!r$r%cs|j‡‡fdd„|DƒŽS)Nc3s|]}| ˆˆ¡VqdSr&r)r0r3r!r"r4�sz)_ResultMixinStr.encode..)Ú_encoded_counterpart©Úselfr+r,r!r3r"r*�sz_ResultMixinStr.encodeN)r$r%)Ú__name__Ú __module__Ú __qualname__Ú__doc__Ú __slots__r*r!r!r!r"r>‹sr>c@seZdZdZdZddd„ZdS) Ú_ResultMixinBytesz>Standard approach to decoding parsed results from bytes to strr!r$r%cs|j‡‡fdd„|DƒŽS)Nc3s|]}| ˆˆ¡VqdSr&r.r0r3r!r"r4˜sz+_ResultMixinBytes.decode..)Ú_decoded_counterpartr@r!r3r"r/—sz_ResultMixinBytes.decodeN)r$r%)rBrCrDrErFr/r!r!r!r"rG“srGc@sDeZdZdZdZedd„ƒZedd„ƒZedd„ƒZed d „ƒZ d S) Ú_NetlocResultMixinBasezHShared methods for the parsed result objects containing a netloc elementr!cCs |jdS)Nr©Ú _userinfo©rAr!r!r"ÚusernameŸsz_NetlocResultMixinBase.usernamecCs |jdS)Nr8rJrLr!r!r"Úpassword£sz_NetlocResultMixinBase.passwordcCsD|jd}|sdSt|tƒr dnd}| |¡\}}}| ¡||S)Nrú%ó%)Ú _hostinfor9r:Ú partitionÚlower)rAÚhostnameÚ separatorZpercentZzoner!r!r"rT§s  z_NetlocResultMixinBase.hostnamecCsl|jd}|dk rhzt|dƒ}Wn(tk rHd|›�}t|ƒd‚YnXd|kr^dkshntdƒ‚|S)Nr8é z+Port could not be cast to integer value as riÿÿzPort out of range 0-65535)rQÚintÚ ValueError)rAÚportÚmessager!r!r"rY²s  z_NetlocResultMixinBase.portN) rBrCrDrErFÚpropertyrMrNrTrYr!r!r!r"rI›s   rIc@s(eZdZdZedd„ƒZedd„ƒZdS)Ú_NetlocResultMixinStrr!cCsD|j}| d¡\}}}|r4| d¡\}}}|s:///;?# Return a 6-tuple: (scheme, netloc, path, params, query, fragment). Note that we don't break the components up in smaller bits (e.g. netloc is a single string) and we don't expand % escapes.ú;r)r=rÚ uses_paramsÚ _splitparamsr) rrÚschemeÚallow_fragmentsÚ_coerce_resultZ splitresultr`ÚqueryrqÚparamsÚresultr!r!r"rzs cCsRd|kr,| d| d¡¡}|dkr6|dfSn | d¡}|d|…||dd…fS)Nú/ryrrr8)ÚfindÚrfind)rrÚir!r!r"r{Šs   r{cCsHt|ƒ}dD]"}| ||¡}|dkr t||ƒ}q |||…||d…fS)Nz/?#r)ÚlenrƒÚmin)rrÚstartÚdelimÚcZwdelimr!r!r"Ú _splitnetloc“s   r‹cCsŠ|r | ¡rdSddl}| dd¡}| dd¡}| dd¡}| dd¡}| d|¡}||kr`dSdD] }||krdtd |d d ƒ‚qddS) Nrr]rr^roú?ÚNFKCz/?#@:znetloc 'z' contains invalid z#characters under NFKC normalization)ÚisasciiÚ unicodedataÚreplaceÚ normalizerX)r`r�ÚnZnetloc2rŠr!r!r"Ú _checknetloc›s       ÿr“cCstD]}| |d¡}q|S)Nr)Ú_UNSAFE_URL_BYTES_TO_REMOVEr�)rrÚbr!r!r"Ú_remove_unsafe_bytes_from_url­sr–c Cs„t||ƒ\}}}t|ƒ}t|ƒ}| t¡}| t¡}t|ƒ}|||t|ƒt|ƒf}t |d¡}|rj||ƒSt tƒt kr|t ƒd}}}|  d¡} | dk�rÒ|d| …dk�rn|| dd…}|dd…dk�r t |dƒ\}}d |krðd |k�sd |k�r d |k�r td ƒ‚|�r,d |k�r,| d d¡\}}d |k�rF| d d¡\}}t|ƒtd||||ƒ} | t|<|| ƒS|d| …D]} | tk�rz�qÒ�qz|| dd…} | �r¼tdd„| Dƒƒ�rÒ|d| … ¡| }}|dd…dk�r"t |dƒ\}}d |k�rd |k�sd |k�r"d |k�r"td ƒ‚|�rBd |k�rB| d d¡\}}d |k�r\| d d¡\}}t|ƒt|||||ƒ} | t|<|| ƒS)aParse a URL into 5 components: :///?# Return a 5-tuple: (scheme, netloc, path, query, fragment). Note that we don't break the components up in smaller bits (e.g. netloc is a single string) and we don't expand % escapes.Nrr^rrr8éú//rdrezInvalid IPv6 URLrorŒcss|]}|dkVqdS)Ú 0123456789Nr!©r1rŠr!r!r"r4ßszurlsplit..)r=r–ÚlstripÚ_WHATWG_C0_CONTROL_OR_SPACEÚstripÚboolÚtyperÚgetr†ÚMAX_CACHE_SIZEr#rƒr‹rXÚsplitr“rÚ scheme_charsÚanyrS) rrr|r}r~ÚkeyÚcachedr`rrqr…ÚvrŠÚrestr!r!r"r²sn       ÿÿ   ÿÿ cCs<t|Ž\}}}}}}}|r&d||f}|t|||||fƒƒS)zúPut a parsed URL back together again. This may result in a slightly different, but equivalent URL, if the URL that was parsed originally had redundant delimiters, e.g. a ? with an empty query (the draft states that these are equivalent).z%s;%s)r=r)Ú componentsr|r`rrr€rrqr~r!r!r"rñs ÿ cCs˜t|Ž\}}}}}}|s4|r`|tkr`|dd…dkr`|rP|dd…dkrPd|}d|pXd|}|rp|d|}|r€|d|}|r�|d |}||ƒS) akCombine the elements of a tuple as returned by urlsplit() into a complete URL as a string. The data argument can be any five-item iterable. This may result in a slightly different, but equivalent URL, if the URL that was parsed originally had unnecessary delimiters (for example, a ? with an empty query; the RFC states that these are equivalent).Nr—r˜r8r‚rr^rŒro)r=Ú uses_netloc)r©r|r`rrrrqr~r!r!r"rüsÿ    c Cs¶|s|S|s|St||ƒ\}}}t|d|ƒ\}}}}}} t|||ƒ\} } } } }}| |ks`| tkrh||ƒS| tkr�| rŒ|t| | | | ||fƒƒS|} | sÀ| sÀ|} |} |s¨|}|t| | | | ||fƒƒS| d¡}|ddkrÜ|d=| dd…dkrø|  d¡}n(||  d¡}td|dd…ƒ|dd…<g}|D]P}|dk�r\z | ¡Wntk �rXYnXn|dk�rl�q(n |  |¡�q(|ddk�r’|  d¡|t| | d  |¡�p¨d| ||fƒƒS) zaJoin a base URL and a possibly relative URL to form an absolute interpretation of the latter.rr‚éÿÿÿÿNr8ú..Ú.)r­r¬) r=rÚ uses_relativerªrr¢ÚfilterÚpopÚ IndexErrorÚappendÚjoin)Úbaserrr}r~ZbschemeZbnetlocZbpathZbparamsZbqueryZ bfragmentr|r`Úpathr€rrqZ base_partsZsegmentsZ resolved_pathZsegr!r!r"rsp ÿ ÿ ÿ ÿ        ÿÿc CsTt|ƒ\}}d|kr>t|ƒ\}}}}}}t|||||dfƒ}nd}|}|t||ƒƒS)z¿Removes any existing fragment from URL. Returns a tuple of the defragmented URL and the fragment. If the URL contained no fragments, the second element is the empty string. ror)r=rrr) rrr~Úsr’ÚpÚaÚqZfragZdefragr!r!r"rTs Z0123456789ABCDEFabcdefc CsÌ|s|jdSt|tƒr"| d¡}| d¡}t|ƒdkr<|S|dg}|j}tdkrbdd„tDƒa|dd…D]R}z(|t|dd …ƒ||d d…ƒWqntk r¾|dƒ||ƒYqnXqnd  |¡S) z,unquote_to_bytes('abc%20def') -> b'abc def'.óúutf-8rPr8rNcSs.i|]&}tD]}|| ¡t ||¡“q qSr!)Ú_hexdigr*ÚbytesÚfromhex)r1r¸r•r!r!r"Ú zs ÿ z$unquote_to_bytes..r—) r¢r9r:r*r†r²Ú _hextobyter¼ÚKeyErrorr³)ÚstringÚbitsÚresr²Úitemr!r!r"rgs,     ÿz([-]+)r»r�cCsžt|tƒrtdƒ‚d|kr$|j|S|dkr0d}|dkr 'abc def'. zExpected str, got bytesrONr»r�rr8r—r) r9r½r;r¢Ú_asciirer²Úranger†rr/r³)rÂr+r,rÃrÄr²r…r!r!r"r‡s   Fc CsNi}t|||||||d�}|D]*\} } | |kr>||  | ¡q| g|| <q|S)aXParse a query given as a string argument. Arguments: qs: percent-encoded query string to be parsed keep_blank_values: flag indicating whether blank values in percent-encoded queries should be treated as blank strings. A true value indicates that blanks should be retained as blank strings. The default false value indicates that blank values are to be ignored and treated as if they were not included. strict_parsing: flag indicating what to do with parsing errors. If false (the default), errors are silently ignored. If true, errors raise a ValueError exception. encoding and errors: specify how to decode percent-encoded sequences into Unicode characters, as accepted by the bytes.decode() method. max_num_fields: int. If set, then throws a ValueError if there are more than n fields read by parse_qsl(). separator: str. The symbol to use for separating the query arguments. Defaults to &. Returns a dictionary. )r+r,Úmax_num_fieldsrU)r r²) ÚqsÚkeep_blank_valuesÚstrict_parsingr+r,rÈrUZ parsed_resultÚpairsÚnameÚvaluer!r!r"r £sþ  c@seZdZdZdS)Ú_QueryStringSeparatorWarningz>Warning for using default `separator` in parse_qs or parse_qslN)rBrCrDrEr!r!r!r"rÏÌsrÏz/etc/python/urllib.cfgc Csªt|ƒ\}}t|tƒr | d¡}|r2t|ttfƒsB|dk rBtdƒ‚tƒ}|dk�rRt}d} |dkrrtj   | ¡}d} |dkräz t t ƒ} Wnt k ršYnJX| �:ddl} | jddd�} |  | ¡| j d | dd �}|aW5QRXt } |dk�rd |k�rdd lm}|d tdd�d}n:|dk�r(|}n*t|ƒdk�rRt| ›d| ›d�ddƒ‚|dk �r ||k�r€d| d¡| d ¡}nd| |¡}||k�r tdƒ‚||k�rÀdd„| d¡Dƒ}ndd„| |¡Dƒ}g}|D]È}|�sð|�sð�qÜ| dd¡}t|ƒdk�r4|�rtd|fƒ‚|�rÜ| d¡n�qÜt|dƒ�sH|�rÜ|d dd¡}t|||d �}||ƒ}|d dd¡}t|||d �}||ƒ}| ||f¡�qÜ|S)!aXParse a query given as a string argument. Arguments: qs: percent-encoded query string to be parsed keep_blank_values: flag indicating whether blank values in percent-encoded queries should be treated as blank strings. A true value indicates that blanks should be retained as blank strings. The default false value indicates that blank values are to be ignored and treated as if they were not included. strict_parsing: flag indicating what to do with parsing errors. If false (the default), errors are silently ignored. If true, errors raise a ValueError exception. encoding and errors: specify how to decode percent-encoded sequences into Unicode characters, as accepted by the bytes.decode() method. max_num_fields: int. If set, then throws a ValueError if there are more than n fields read by parse_qsl(). separator: str. The symbol to use for separating the query arguments. Defaults to &. Returns a list, as G-d intended. r$Nz*Separator must be of type string or bytes.ZPYTHON_URLLIB_QS_SEPARATORzenvironment variabler)ro)Z interpolationZcomment_prefixesr )Zfallbackry)ÚwarnaThe default separator of urllib.parse.parse_qsl and parse_qs was changed to '&' to avoid a web cache poisoning issue (CVE-2021-23336). By default, semicolons no longer act as query field separators. See https://access.redhat.com/articles/5860431 for more details.r—©Ú stacklevelú&Zlegacyr8z (from z) must contain z1 character, or "legacy". See z7s zparse_qsl..cSsg|]}|‘qSr!r!)r1rÕr!r!r"r×9sú=zbad query field: %rrú+ú r3)r=r9r½r/r:rXÚobjectÚ_default_qs_separatorÚosÚenvironr ÚopenÚ_QS_SEPARATOR_CONFIG_FILENAMEÚFileNotFoundErrorÚ configparserZ ConfigParserZ read_fileÚwarningsrÐrÏr†Úcountr¢r²r�r)rÉrÊrËr+r,rÈrUr~Z_legacyZ envvar_nameZ config_sourcerrâZconfigrÐÚ num_fieldsrÌÚrZ name_valueZnvrÍrÎr!r!r"r Ôs”      þ    ù ÿþÿ       cCs| dd¡}t|||ƒS)z›Like unquote(), but also replace plus signs by spaces, as required for unquoting HTML form values. unquote_plus('%7e/abc+def') -> '~/abc def' rÙrÚ)r�r)rÂr+r,r!r!r"rQs sBABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789_.-~c@s(eZdZdZdd„Zdd„Zdd„ZdS) ÚQuoterzÌA mapping from bytes (in range(0,256)) to strings. String values are percent-encoded byte values, unless the key < 128, and in the "safe" set (either the specified safe set, or default set). cCst |¡|_dS)zsafe: bytes object.N)Ú _ALWAYS_SAFEÚunionÚsafe)rArêr!r!r"Ú__init__iszQuoter.__init__cCsd|jjt|ƒfS)Nz<%s %r>)Ú __class__rBÚdictrLr!r!r"Ú__repr__mszQuoter.__repr__cCs(||jkrt|ƒnd |¡}|||<|S)Nz%{:02X})rêÚchrÚformat)rAr•rÄr!r!r"Ú __missing__qszQuoter.__missing__N)rBrCrDrErërîrñr!r!r!r"rçasrçr‚cCsbt|tƒr8|s|S|dkrd}|dkr*d}| ||¡}n |dk rHtdƒ‚|dk rXtdƒ‚t||ƒS)a•quote('abc def') -> 'abc%20def' Each part of a URL, e.g. the path info, the query, etc., has a different set of reserved characters that must be quoted. The quote function offers a cautious (not minimal) way to quote a string for most of these parts. RFC 3986 Uniform Resource Identifier (URI): Generic Syntax lists the following (un)reserved characters. unreserved = ALPHA / DIGIT / "-" / "." / "_" / "~" reserved = gen-delims / sub-delims gen-delims = ":" / "/" / "?" / "#" / "[" / "]" / "@" sub-delims = "!" / "$" / "&" / "'" / "(" / ")" / "*" / "+" / "," / ";" / "=" Each of the reserved characters is reserved in some component of a URL, but not necessarily in all of them. The quote function %-escapes all characters that are neither in the unreserved chars ("always safe") nor the additional chars set via the safe arg. The default for the safe arg is '/'. The character is reserved, but in typical usage the quote function is being called on a path where the existing slash characters are to be preserved. Python 3.7 updates from using RFC 2396 to RFC 3986 to quote URL strings. Now, "~" is included in the set of unreserved characters. string and safe may be either str or bytes objects. encoding and errors must not be specified if string is a bytes object. The optional encoding and errors parameters specify how to deal with non-ASCII characters, as accepted by the str.encode method. By default, encoding='utf-8' (characters are encoded with UTF-8), and errors='strict' (unsupported characters raise a UnicodeEncodeError). Nr»r%z,quote() doesn't support 'encoding' for bytesz*quote() doesn't support 'errors' for bytes)r9r:r*r;r )rÂrêr+r,r!r!r"r ws' cCsdt|tƒrd|ks$t|tƒr2d|kr2t||||ƒSt|tƒrBd}nd}t|||||ƒ}| dd¡S)zÞLike quote(), but also replace ' ' with '+', as required for quoting HTML form values. Plus signs in the original string are escaped unless they are included in safe. It also does not have safe default to '/'. rÚó rÙ)r9r:r½r r�)rÂrêr+r,Zspacer!r!r"r ­sÿÿ csªt|ttfƒstdƒ‚|sdSt|tƒr6| dd¡}ntdd„|Dƒƒ}| t|¡s^| ¡Sz t |‰Wn&t k r�t |ƒj t |<‰YnXd  ‡fdd„|Dƒ¡S)zËLike quote(), but accepts a bytes object rather than a str, and does not perform string-to-bytes encoding. It always returns an ASCII string. quote_from_bytes(b'abc def?') -> 'abc%20def%3f' z!quote_from_bytes() expected bytesrr$ÚignorecSsg|]}|dkr|‘qS)é€r!ršr!r!r"r×Ësz$quote_from_bytes..csg|] }ˆ|ƒ‘qSr!r!)r1Úchar©Zquoterr!r"r×Òs)r9r½Ú bytearrayr;r:r*ÚrstripÚ_ALWAYS_SAFE_BYTESr/r rÁrçÚ __getitem__r³)Zbsrêr!rör"r ¾s  c Cs t|dƒr| ¡}nPzt|ƒr0t|dtƒs0t‚Wn0tk rbt ¡\}}}tdƒ |¡‚YnXg} |sà|D]j\} } t| t ƒrŽ|| |ƒ} n|t | ƒ|||ƒ} t| t ƒr¶|| |ƒ} n|t | ƒ|||ƒ} |   | d| ¡qp�n"|D�]\} } t| t ƒ�r|| |ƒ} n|t | ƒ|||ƒ} t| t ƒ�rB|| |ƒ} |   | d| ¡qät| t ƒ�rp|| |||ƒ} |   | d| ¡qäz t| ƒ} Wn:tk �r¶|t | ƒ|||ƒ} |   | d| ¡YqäX| D]B} t| t ƒ�rØ|| |ƒ} n|t | ƒ|||ƒ} |   | d| ¡�q¼qäd  | ¡S)a^Encode a dict or sequence of two-element tuples into a URL query string. If any values in the query arg are sequences and doseq is true, each sequence element is converted to a separate parameter. If the query arg is a sequence of two-element tuples, the order of the parameters in the output will match the order of parameters in the input. The components of a query arg may each be either a string or a bytes type. The safe, encoding, and errors parameters are passed down to the function specified by quote_via (encoding and errors only if a component is a str). Úitemsrz1not a valid non-string sequence or mapping objectrØrÓ) Úhasattrrûr†r9r5r;ÚsysÚexc_infoÚwith_tracebackr½r:r²r³)rZdoseqrêr+r,Z quote_viaZtyZvaÚtbÚlÚkr§r2Zeltr!r!r"rÔsR  ÿ              cCstjdtdd�t|ƒS)Nz/urllib.parse.to_bytes() is deprecated as of 3.8r—rÑ)rãrÐÚDeprecationWarningÚ _to_bytes©rrr!r!r"Úto_bytes%s ÿrcCsJt|tƒrFz| d¡ ¡}Wn(tk rDtdt|ƒdƒ‚YnX|S)zto_bytes(u"URL") --> 'URL'.ÚASCIIzURL z contains non-ASCII characters)r9r:r*r/Ú UnicodeErrorÚreprrr!r!r"r+s  ÿ rcCs`t|ƒ ¡}|dd…dkr<|dd…dkr<|dd… ¡}|dd…dkr\|dd… ¡}|S)z“Transform a string like '' into 'scheme://host/path'. The string is returned unchanged if it's not a wrapped URL. Nr8úézURL:)r:r�rr!r!r"Úunwrap9s   r cCstjdtdd�t|ƒS)NzUurllib.parse.splittype() is deprecated as of 3.8, use urllib.parse.urlparse() insteadr—rÑ)rãrÐrÚ _splittyperr!r!r"Ú splittypeFs þrcCsDtdkrt dtj¡at |¡}|r<| ¡\}}| ¡|fSd|fS)z:splittype('type:opaquestring') --> 'type', 'opaquestring'.Nz ([^/:]+):(.*))Ú _typeprogÚreÚcompileÚDOTALLÚmatchÚgroupsrS)rrrr|Údatar!r!r"rNs   rcCstjdtdd�t|ƒS)NzUurllib.parse.splithost() is deprecated as of 3.8, use urllib.parse.urlparse() insteadr—rÑ)rãrÐrÚ _splithostrr!r!r"Ú splithost[s þrcCsXtdkrt dtj¡at |¡}|rP| ¡\}}|rH|ddkrHd|}||fSd|fS)z;splithost('//host[:port]/path') --> 'host[:port]', '/path'.Nz//([^/#?]*)(.*)rr‚)Ú _hostprogrrrrr)rrrZ host_portrµr!r!r"rcs  rcCstjdtdd�t|ƒS)NzUurllib.parse.splituser() is deprecated as of 3.8, use urllib.parse.urlparse() insteadr—rÑ)rãrÐrÚ _splituser©Úhostr!r!r"Ú splituserrs þrcCs | d¡\}}}|r|nd|fS)zJsplituser('user[:passwd]@host[:port]') --> 'user[:passwd]', 'host[:port]'.r]N©ra)rÚuserr‰r!r!r"rysrcCstjdtdd�t|ƒS)NzWurllib.parse.splitpasswd() is deprecated as of 3.8, use urllib.parse.urlparse() insteadr—rÑ)rãrÐrÚ _splitpasswd)rr!r!r"Ú splitpasswds þr!cCs | d¡\}}}||r|ndfS)z/splitpasswd('user:passwd') -> 'user', 'passwd'.r^N©rR)rr‰Zpasswdr!r!r"r †sr cCstjdtdd�t|ƒS)NzUurllib.parse.splitport() is deprecated as of 3.8, use urllib.parse.urlparse() insteadr—rÑ)rãrÐrÚ _splitportrr!r!r"Ú splitportŒs þr$cCsDtdkrt dtj¡at |¡}|r<| ¡\}}|r<||fS|dfS)z*splitport('host:port') --> 'host', 'port'.Nz (.*):([0-9]*))Ú _portprogrrrÚ fullmatchr)rrrYr!r!r"r#•s  r#r«cCstjdtdd�t||ƒS)NzVurllib.parse.splitnport() is deprecated as of 3.8, use urllib.parse.urlparse() insteadr—rÑ)rãrÐrÚ _splitnport)rÚdefportr!r!r"Ú splitnport£s þr)cCsT| d¡\}}}|s|}n2|rLz t|ƒ}Wntk rBd}YnX||fS||fS)zÛSplit host and port, returning numeric port. Return given default port if no ':' found; defaults to -1. Return numerical port if a valid number are found after ':'. Return None if ':' but not a valid number.r^N)rarWrX)rr(r‰rYZnportr!r!r"r'ªs  r'cCstjdtdd�t|ƒS)NzVurllib.parse.splitquery() is deprecated as of 3.8, use urllib.parse.urlparse() insteadr—rÑ)rãrÐrÚ _splitqueryrr!r!r"Ú splitquery»s þr+cCs$| d¡\}}}|r||fS|dfS)z/splitquery('/path?query') --> '/path', 'query'.rŒNr)rrrµr‰rr!r!r"r*Âsr*cCstjdtdd�t|ƒS)NzTurllib.parse.splittag() is deprecated as of 3.8, use urllib.parse.urlparse() insteadr—rÑ)rãrÐrÚ _splittagrr!r!r"ÚsplittagÊs þr-cCs$| d¡\}}}|r||fS|dfS)z)splittag('/path#tag') --> '/path', 'tag'.roNr)rrrµr‰Útagr!r!r"r,Ñsr,cCstjdtdd�t|ƒS)NzUurllib.parse.splitattr() is deprecated as of 3.8, use urllib.parse.urlparse() insteadr—rÑ)rãrÐrÚ _splitattrrr!r!r"Ú splitattrÙs þr0cCs| d¡}|d|dd…fS)zksplitattr('/path;attr1=value1;attr2=value2;...') -> '/path', ['attr1=value1', 'attr2=value2', ...].ryrr8NrÔ)rrZwordsr!r!r"r/às r/cCstjdtdd�t|ƒS)NzWurllib.parse.splitvalue() is deprecated as of 3.8, use urllib.parse.parse_qsl() insteadr—rÑ)rãrÐrÚ _splitvalue)Úattrr!r!r"Ú splitvalueçs þr3cCs | d¡\}}}||r|ndfS)z-splitvalue('attr=value') --> 'attr', 'value'.rØNr")r2r‰rÎr!r!r"r1îsr1)rT)r)rT)T)r»r�)FFr»r�NN)FFr»r�NN)r»r�)r‚NN)rNN)r‚)r«)r«)nrErrÝrýÚ collectionsrãÚ__all__r®rªrzZnon_hierarchicalZ uses_queryZ uses_fragmentr£rœr”r¡rr#Z_implicit_encodingZ_implicit_errorsr(r-r7r=rÛr>rGrIr\rirnZ_DefragResultBaseZ_SplitResultBaseZ_ParseResultBaserrrqr|r`rµrr€Z ResultBaserrrrrrrxrr{r‹r“r–rrrrrr¼rÀrrrÆrr ÚRuntimeWarningrÏràrÜr rÚ frozensetrèr½rùr Ú defaultdictrçr r r rrrr rrrrrrrrr!r r$r%r#r)r'r+r*r-r,r0r/r3r1r!r!r!r"Ús¶!û ý ü þÿÿ þ  ÿ ÿ %  ÿÿ         ?  E  ÿ )ÿ }  6  ÿ Q